HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't apply profile to blade

Kerry Quillen
Regular Advisor

Can't apply profile to blade

I just added my 7th blade enclosure to Oneview. This enclosure was in production and consists of all BL460C Gen8 blades booting ESXi 6.0 from SD card. Oneview is at 3.10. I created all profiles from same template and 15 of the blades boot fine. One however will fail during the profile application just after the ILO console displays message "Boot device is being configured by Virtual Connect. System will reboot shortly...". When the failure occurs, the console displays "This is not a bootable disk. Please insert a bootable floppy and press any key...". If I unassign the profile and reboot the blade it boots ESXi just fine. I've tried numerous things - reset ILO, reseat the blade, create a fresh profile, reset bios to defaults, reinstall intelligent provisioning, etc, etc. Nothing works. There are no errors in ILO logs. Errors reported in Oneview are:

Unable to get response back from Smart Update Tool within the expected amount of time.

The firmware update operation failed. Unable to boot the SPP.

5 REPLIES
ChrisLynchHPE
Neighborhood Moderator

Re: Can't apply profile to blade

The behavior you are experiencing is similar to the reported iLO issues other customers have discussed here. Please see this CA: http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c04996097. If your iLO firmware is older than 2.55, please update it and follow the guidance in the CA.
Kerry Quillen
Regular Advisor

Re: Can't apply profile to blade

I upgraded ILO fw from 2.50 to 2.54 and the issue is resolved.  Thanks

Saunders
Occasional Advisor

Re: Can't apply profile to blade

I am having this problem at well. Running OneView 4.0, BL460 G8, running ILO code 2.55. 

Oneview is able to apply an SPP image to the blade, and the blade completes firmware installation process, but after reboot, I get the error "This is not a bootable disk. Please insert a bootable floppy and press any key to try again". 


bios_error.JPG

I read over that other thread and the blade does not appear to be an a UFEI mode at all. I am also having the issue against multiple blades in multiple chassis, but all of them BL460 G8s. 

I have tried removing/reapplying the profile, different SPPs, etc. 

Any ideas? 

peyrache
Respected Contributor

Re: Can't apply profile to blade

Shall you select bootable tab on disk target ?
kevins550
Occasional Visitor

Re: Can't apply profile to blade

This may be the problem I identified with HPE and am currently waiting for an engineering fix.  Due to Oneview using the SPP management OS for making changes to the blade (which you will see in the details of the update task) even if you don't choose to update the firmware.  The SPP management OS is failing with Gen8 blades, but this is only used if you are making BIOS or local storage changes in my experience.  The work around is to not make all of these changes in one go, apply the profile without the BIOS settings so that the connections and local storage are applied, then update the profile to add in the BIOS settings.

If you do not have SPP bundles in the OneView repository, this doesn't apply and OneView will use Intelligent provisioning to apply all the changes in one go and this works fine wih no errors..

This is a change that came in with Oneview 3.10.x and SPP later that 2017.10.  I can see the benefit of using the SPP as new features can be introduced without having to refresh Intelligent Provisioning on each iLO instance.  It just doesn't seem to have been fully tested on Gen8 blades, later blades all work OK.