HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Cant update Oneview to 5.0

 
Highlighted
malacoda
Occasional Visitor

Cant update Oneview to 5.0

Trying to update from version 4.20.02-0395878 to 5.0 I am getting the error:

Upload (time varies depending on file size and network speed/bandwidth).
Received HPE_OneView_5.00_update_Z7550-96604.bin.
Verify image integrity and applicability (will take several minutes).
Issue The update image HPE_OneView_5.00_update_Z7550-96604.bin is not compatible with the appliance platform and will be deleted.
Resolution Select a compatible update image for the appliance platform and try again.
 
Is there a different update bin file aside from the one I grabbed from the software depot?

 

5 REPLIES 5
ChrisLynchHPE
Neighborhood Moderator

Re: Cant update Oneview to 5.0

Yes, changes were made to the update bin files that are not compatible between appliance types. You will need to download the correct upgrade bin for the specific appliance type. The hyperlink in the UI will be fixed in a patch release.

So, if you are trying to apply the upgrade bin for VMA to Synergy Composer, you have the wrong uodate. And it is not quite available yet.

Accept or Kudo

JMJM
Occasional Visitor

Re: Cant update Oneview to 5.0

I'm also having trouble. I've tried the HPE OneView 5.00 update(Z7550-96604a.bin) update and, today, HPE OneView 5.00.00.01 Update (Z7550-96766.bin). Same thing happens on both, it uploads fine and starts the installation, then gets to around 14% and returns this:

 

Unable to update appliance.

The appliance is at pre-update version 4.20.02-0395878

PatrickLong
Advisor

Re: Cant update Oneview to 5.0

@JMJM Assuming you are attempting this on a Composer hardware OneView appliance, I suspect you need to first run the HPE_PreUpgrade_4.20_5.00 file mentioned here  >> https://h20392.www2.hpe.com/portal/swdepot/displayProductInfo.do?productNumber=synergy_rs_00.00

But I'm having trouble with the 5.00.00.01 download links on that page now, when I click through to get to the myenterpriselicense.hpe.com site where I would normally see the downloads, it now comes up with an error "Invalid Product Selected"

I have noot seen anything written to indicate that this same type of PreUpgrade process would also required for upgrades of the standard OneView VMA appliance (i.e. NOT Composer hardware appliances) BUT I would caution that guidance may change as the day goes on., especially since I just discovered  a "HPE Preupgrade 4.20_5.00 (Z7550-96608.bin)" file now appears in the downloads for the VMA appliance which was definitely NOT there this morning...

I am going to let this 5.0.x upgrade process hash itself out over the next few days and revisit when HPE has everything ironed out and all written guidance is appropriately updated.

PreUpgrade_VMA.png

 

ChrisLynchHPE
Neighborhood Moderator

Re: Cant update Oneview to 5.0

The Pre-Upgrade is only for HPE Synergy Composer 1 and is to address a very specific issue there. 


Accept or Kudo

PatrickLong
Advisor

Re: Cant update Oneview to 5.0

Thanks Chris.  I have Composer 1's @ 4.20.02 and OneView VM appliancees at 4.20.02 at multiple locations in my environment, so it is good to konw that the PreUpgrade .bin only needs to be applied to the Composer 1's.  Thank you for the quick response!