HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

 
SOLVED
Go to solution
PatrickLong
Advisor

Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

The HPE Synergy Software Releases - OverView notes that "Immediately before upgrading to HPE OneView 4.20.02 or HPE OneView 5.00.00.01, install HPE_PreUpgrade_4.20_5.00_Z7550-96608.bin."  I am curious what exactly this binary does to prepare the Composer for upgrade, as I cannot find any information other than what appears on that page related to how long it might take and what progress information I'll see? 

Also, it is interesting that this PreUpgrade file and the assocoated IMPORTANT: note appear on the HPE Synergy Composer Oneview downloads page ONLY and do NOT appear (nor is there an IMPORTANT warning to apply a PreUpgrade file) on the standard OneView VMA Overview or download pages.  From this should I infer that this extra PreUgrade step is only required for Composer OneView upgrades  to 4.20.02 or 5.00.00.01 - and NOT required for standard OneView VMA upgrades to those same versions?

6 REPLIES 6
PatrickLong
Advisor
Solution

Re: Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

per @ChrisLynchHPE in another thread: "The Pre-Upgrade is only for HPE Synergy Composer 1 and is to address a very specific issue there."    So that explains it - it's only for Composer 1 OneView hardware appliances,  NOT for OneView virtual appliances.

ChrisLynchHPE
Neighborhood Moderator

Re: Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

There is also supposed to be a link to a CA that describes the pre-upgrade bin file for Synergy Composer 1. Did you not see that link?

Accept or Kudo

PatrickLong
Advisor

Re: Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

Sorry Chris I do not see any link to a specific CA describing the pre-upgrade .bin for Synergy Composer 1 on the page HPE Synergy Software Releases - OverView .  There is a link to the HPE OneView 5.0 Release Notes for HPE Synergy , which includes a Section titled "Intermediate upgrade to HPE OneView version 4.20.02" and subsection titled "Extract and apply PreUpgrade.bin file" which describes the process by which you apply the file, but those sections do not describe purpose of the .bin file or what the file does.

DanCernese0
HPE Pro

Re: Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

Apologies on behalf of HPE-- there has been several missing parts to the page updates.  There should have been a CA as Chris said but there is not.  The preUpgrade file is required for the HPE OneView virtual appliance, the HPE Synergy Composer, for 4.20.02 and 5.00.00.01.  All of those pages have since been update to say that (yes, even the VM appliance does now).

The purpose of the preUpgrade is simply to avoid the possibility of the upgrade failing and rolling back due in some environments where there have been interconnect reseats causing unexpected results in prior versions.  This is fixed in future versions but the upgrade task itself didn't clean up properly, thus the preUpgrade rather than spinning the release again.

I am an HPE Employee
Accept or Kudo
dru37
Occasional Visitor

Re: Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

Hi, I am trying to upgrade Composer from 4.20.01.01-0385523 --> to ----> 5.00.00.01 with error: The update image HPE_OneView_5.00.00.01_Update_Z7550-96766.bin is not compatible with the appliance platform and will be deleted. I cannot find the "hpe_preupgrade_4 20_5 00_z7550-96608. bin" as instructed in the installation instructions. Can you share some information how I can bypass this issue to successfully upgrade to Oneview 5.0 or upload the deisred file on the HPE support Centre?

Thanks.

Mike1295
Occasional Visitor

Re: Composer OneView 4.20.02/5.00.00.01 Pre-Upgrade requirement?

You'll need an active support license for your Synergy but you can get the software here:

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_b7eb05fbaf394432b7f6791629#tab1

Once you authenticate you'll get to a download page with a list of software and checkboxes.  Uncheck the ones that you don't want and download the ones that you do.

-Mike