HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Error when adding C7000 enclosure - "The enclosure is already added by this appliance"

Mick Ryan
Advisor

Error when adding C7000 enclosure - "The enclosure is already added by this appliance"

Hi all

 

I've added 6 enclosures to our OneView screen, but on the 7th I got this error message:

"The enclosure is already added by this appliance"

 

I've done a search via name and IP address, but it's not in there. Any thoughts or suggestions on what could be going wrong or how I can fix this?

 

Cheers

 

Mike

5 REPLIES
ChrisLynchHPE
Neighborhood Moderator

Re: Error when adding C7000 enclosure - "The enclosure is already added by this appliance"

Have you previously attempted to add this 7th enclosure before?  Is the Enclosure Name the same as another you have already added?  When you navigate to Enclosures, are you sure you don't see it listed?  If you log into the enclosures Priamry OA via SSH, and execute 'show vcmode', what is displayed?

Mick Ryan
Advisor

Re: Error when adding C7000 enclosure - "The enclosure is already added by this appliance"

Hi Chris

 

This is what it shows

> show vcmode

Virtual Connect Mode: Disabled

 

I may have added this before and deleted it now. However, I don't see it in the the list of enclosures and whenever I search for it I can't find it, using either the name or the IP address

 

I just tried adding it using the secondary IP address but that also gave the same message about the enclosure already being there

 

I went through the config of all the other 6 enclosures that are currently in there, just to double-check that none had assumed its identity with the same IP address or anything like that

 

Do you know whether there's some kind of utility available to validate the internal database in OneView?

 

Cheers

 

Mike

ChrisLynchHPE
Neighborhood Moderator

Re: Error when adding C7000 enclosure - "The enclosure is already added by this appliance"

You will need to open a support case to handle the resolution to your issue.  The forums here are not capable of supporting the resolution to your issue, or issues like this, and will require a support engineer to further assist.

Mick Ryan
Advisor

Re: Error when adding C7000 enclosure - "The enclosure is already added by this appliance"

To close this out, I found out what the problem is from trial and error. I eventually found the two enclosures that wouldn't play nicely together in OneView and then compared the settings. Low and behond, the Onboard Administrator thinks that both enclosures have the same Serial Number

 

I'm not sure how this gets set, but at least I know why OneView wouldn't accept them both at the same time

 

Mike

ChrisLynchHPE
Neighborhood Moderator

Re: Error when adding C7000 enclosure - "The enclosure is already added by this appliance"

Hmm....  Did the midplane ever get replaced in one of your enclosures?