HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Fails to apply 2016.10.0 bundle using SUT 1.6.5.0

DPS_IT
Occasional Advisor

Fails to apply 2016.10.0 bundle using SUT 1.6.5.0

Hi there,

I have recently been trialing the installation of a SPP (2016.10.0) installed in oneview, staged and deployed using SUT although when i run hpsut /stage the error i recieve is 

Mounted ISO is not an SPP image Staging Failed

I looked further into the logs and it noted

Bundle XML file is not found in this ISO; ISO is not a valid SPP

Curious i tried redownloading the SPP https://www.hpe.com/us/en/product-catalog/detail/pip.5104018.html# although that didnt work so then i tried to create a custom SPP although the latter i could not add as a firmware bundle to oneview because it was missing specific drivers. (Strange since i selected all apart from the operating systems not being used and server chassis)

Anyway i am assuming that HPE SPP's can be added to Oneview in order to create firmware/software baselines or are there Oneview SPP's that i need to use?

Thanks

Mark

 

3 REPLIES
ChrisLynchHPE
Neighborhood Moderator

Re: Fails to apply 2016.10.0 bundle using SUT 1.6.5.0

We do not publish HPE OneView specific baselines (aka SPP's).  I would check the ISO MD5/SHA256 hash of the one you downloaded just to make sure they match (you can use the Get-FileHash PowerShell Cmdlet to generate the SHA256, or other algorithm, hash).

You can also try to create your own custom SPP.  Your HPE Passport account must be tied to the SIAD or active warranty for a supported HPE server in order to access the Custom SPP service.  You'll need to make sure that you follow these steps:

  1. Choose any of the released available SPP's as your base.
  2. Select the Custom Baseline button.
  3. Provide a Description, which will become the baseline name, and set the version.  Make sure that Bootable is selected before continuing.
  4. Match the filter set to this image at a minimum:

Custom SPP Filter Set for HPE OneView.png

The items selected in the filter are needed to make sure that the C-Class Onboard Administrator, Virtual Connect, iLO3 and iLO4 firmware are present within the baseline, which are required today for HPE OneView to accept the ISO as a valid baseline.  Please know that those above are not applicable for HPE Synergy baselines, and there is a seperate filter option for HPE Synergy.

That's it.  You can always add more items, but that will increase the size of the ISO.

If you are still unable to deploy your baseline with HPSUT, I would suggest you open a support case.

DPS_IT
Occasional Advisor

Re: Fails to apply 2016.10.0 bundle using SUT 1.6.5.0

HI Chris i appreicate the quick reply.

 

Curious i am assuming you selected SLES 11 since you are installing this custom SPP pack on a suse linux os?

My requirements are server 2012r2 and chassis DL380 gen9. I have tried to create another SPP from that webiste mentioned although the custom bundle returns with a large hazard sign over top which only allows me to view or delete. (issue with the cloud build process prehaps). Tried different browsers. logged out then back in although same issue.

I then tried again from a newly downloaded SPP 2016.10 iso to create a custom baseline although once i add it to OV i receive the error that OA, iLO3 and VC Firmware in not present even though i did select those options during the build process.

All servers are currently running on 2016.04

Interesting times

 

DPS_IT
Occasional Advisor

Re: Fails to apply 2016.10.0 bundle using SUT 1.6.5.0

Hi there,

This issue still persists with 2017.04

As noted previously we just need Server 2012r2 and DL380Gen9.

I have ticked all other options.

I am taking a hunch that you need to add RLES 11 and 12 as well in order to upload it successfully to oneview?