HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

FlexLOM nics and VLANS problems

Rimvydas
Frequent Advisor

FlexLOM nics and VLANS problems

Hi,

So here is my situation. I have c7000 G3 enclosure with BL460c blades in it and HP FlexFabric 20Gb 2-port 650FLB Adapters in each blade. As you may know, this adapter has two physical ports which I can subdivide into virtual ports. Lets assume that I want to create two virtual ports on the same physical port on this adapter. I want to know exact reason why can't I assign THE SAME VLAN on these two ports/ Why are there such shortcomming? Thanks.

2 REPLIES
ChrisLynchHPE
Neighborhood Moderator

Re: FlexLOM nics and VLANS problems

This has been a rule within Virtual Connect ever since we introduced Flex-10 products.  The reason is that Virtual Connect cannot dissern between a frame that should go to which Physical Function if they are on the same VLAN. 

What is the reationale behind needing to do this?  There have been only a few of our 1000's of VC customers that had a very specific application where they needed to implement this.

You can, and it will require you to utilize multiple uplinks, with different internal VLAN ID's, along without VLAN tagging.

Rimvydas
Frequent Advisor

Re: FlexLOM nics and VLANS problems

Hi,

Reason is very simple - we had physical servers till these blades. Servers were ESXi servers. And we had following configuration - one nic for management traffic and another nic for vmotion and FT. Both nics were in the same vlan and were in the teaming mode with two more nics. So with blades we can't have such configuration:(

Chris, one more question. I must be able to subdivide out flexlom adapters to 16 ports but I'm able to divide this flexlom only to 8 ports. Do you know how to fix this? I'm on 3.08 OV and with the latest firmwares on OA, VC and blades.