HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

I upgraded to 4..10.1732.2495 no error messages but not 100% sure if it upgraded

 
Mtgreene85
Occasional Contributor

I upgraded to 4..10.1732.2495 no error messages but not 100% sure if it upgraded

I upgraded the powershell cmdlets. When I connect to a Oneview appliance I see

Welcome to the HPE OneView POSH Library, v3.10.1731.3550
        --------------------------------------------------------

 To get a list of available CMDLETs in this library, type :  Get-Command -module HPOneView.310
 To get help for a specific command, type:                   get-help [verb]-HPOV[noun]
 To get extEnded help for a specific command, type:          get-help [verb]-HPOV[noun] -full
 To update the offline help for this module, type:           Update-Help -module HPOneView.310

 Module sample scripts are located at: C:\Program Files\WindowsPowerShell\Modules\HPOneView.310\Samples

 

 

When I look at the modules I see the following below Script     4.10.17... HPOneView.410

ModuleType Version    Name                                ExportedCommands
---------- -------    ----                                ----------------
Script     3.10.17... HPOneView.310                       {Enable-HPOVMSDSC, Disable-HPOVMSDSC, Send-HPOVRequest, Ping-HPOVAddress...}
Script     1.1.3.15   FormatPX                            {Format-Custom, Format-Default, Format-List, Format-Table...}
Binary     1.0.6.19   SnippetPx                           {Get-Snippet, Invoke-Snippet}
Binary     1.0.5.18   SnippetPx                           {Get-Snippet, Invoke-Snippet}
Script     4.10.17... HPOneView.410                       {Enable-HPOVMSDSC, Disable-HPOVMSDSC, Send-HPOVRequest, Ping-HPOVAddress...}
Manifest   0.0        HPOneView.410

Was it upgraded ?

1 REPLY 1
Aarti_Verma
Occasional Contributor

Re: I upgraded to 4..10.1732.2495 no error messages but not 100% sure if it upgraded

As we see in the list of modules both HPEOneView310 and HPEOneView410 both the module exist. This is the cause of the problem as powershell is loading the older module. As i understand you want to use the latest module i.e. HPEOneView410.

I would suggest you to delete the folder and files of HPEOneView310 module from the system and then try once.
you can get the Path property from the output of Get-Module for HPEOneView310 module.

Regards,
Aarti Verma