HPE OneView

Import-Module HPEOneView.550 The library is unable to load

 
SOLVED
Go to solution
Gammal1
Visitor

Import-Module HPEOneView.550 The library is unable to load

Hi Experts , 

Im trying to import "Import-Module HPEOneView.550" its giving me this error 

Import-Module : The library is unable to load due to this sytem missing the required .NetFramework 4.7.2 client.
Please visit https://go.microsoft.com/fwlink/?LinkId=863265 to download the .NetFramework 4.7.2 Offline Installer.
At line:1 char:1
+ Import-Module HPEOneView.550
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ResourceUnavailable: (Import-Module HPEOneView.550:String) [Import-Module], InvalidOpera
tionException
+ FullyQualifiedErrorId : UnableToLoadModuleMissingDependancy,Microsoft.PowerShell.Commands.ImportModuleCommand

my $PSVersionTable 

Name Value
---- -----
PSVersion 5.1.16299.1146
PSEdition Desktop
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0...}
BuildVersion 10.0.16299.1146
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

my Laptop is Windows 10 Based , version 1709 , 

am i missing somthing ? 

Kind Regards ,

Mohamed ELGammal

 

2 REPLIES 2
ChrisLynch
HPE Pro
Solution

Re: Import-Module HPEOneView.550 The library is unable to load

Ideally, you should be asking this over on the GitHub HPE OneView PowerShell project issue tracker or Discussions.   SO for future reference, please use that location to engage us for support.

What does the output from the following return:

 

Get-Item 'HKLM:\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full\' |  Get-ItemPropertyValue -Name Release

 

There should be only 1 string returned, and it should be greater than 461808.  If the string value is less than that, you may have removed the .Net Framework feature from Windows.  Do know that WIndows 10 1709 shipped with the .Net Framework client 4.7.1 (documented here, you will see under the 4.7.1 section), which is likely being detected.  So, you will need to download and install at least the 4.7.2 or newer installer.


I am an HPE employee

Accept or Kudo

Gammal1
Visitor

Re: Import-Module HPEOneView.550 The library is unable to load

Hi Chris , 

Thank you it worked for me , 

the  string value was less than 461808 ,  so i installed the .Net frame work 4.8 and re-run the command again could see that the string version is 528049 , and the Import-Module ran just fine afterwards , Thank you so much 

Will make sure to post at the discussion page in future issues . 

Kind Regards ,

Mohamed ELGammal