HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Installation error when I install HP Oneview for Vcenter

orix1
Occasional Visitor

Installation error when I install HP Oneview for Vcenter

When I install HP Oneview for Vcenter, I get an error just before the installation ends.  When I check it in Windows EventViewer, it shows: 

 

The description for Event ID 3 from source HPOV4VCUIM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Traceback (most recent call last):

File "win32serviceutil.pyo", line 806, in SvcRun

File "hpuim.pyo", line 50, in SvcDoRun

File "uim.pyo", line 17, in <module>

File "web\__init__.pyo", line 14, in <module>

File "web\wsgi.pyo", line 8, in <module>

File "web\http.pyo", line 17, in <module>

File "web\webapi.pyo", line 31, in <module>

File "cgi.pyo", line 51, in <module>

File "mimetools.pyo", line 6, in <module>

File "tempfile.pyo", line 34, in <module>

File "random.pyo", line 883, in <module>

File "random.pyo", line 97, in __init__

File "random.pyo", line 111, in seed

WindowsError: [Error -2146893795] Provider DLL failed to initialize correctly

the message resource is present but the message is not found in the string/message table

 

 

Does anyone getting the same error?  Help please.

 

 

 

P.S. This post has been split off from other thread, and moved to HP OneView. - HP Forum Moderator

3 REPLIES
ChrisLynchHPE
Neighborhood Moderator

Re: Installation error when I install HP Oneview for Vcenter

Hello orix1, and welcome to the HP OneView Community Forums.

 

Please know that these forums are not for official product support, and is here for the community to assist one another.  If you require immediate assistance for resolution, I would suggest you open a support case.

 

That being said, if you wish to continue using this forum, please provide the following details:

 

  • HP OneView for vCenter version
  • Windows version
  • Are you performing an upgrade of an existing installation?
xxFreelancexx
Occasional Visitor

Re: Installation error when I install HP Oneview for Vcenter

Anyone solve this?

sysadmin4151
Occasional Advisor

Re: Installation error when I install HP Oneview for Vcenter

This is an old thread that got revived, but I just tried the new OneView for vCenter and got a similiar error.

HP OneView for vCenter 7.8.1 on Windows 2008 R2 SP1. Doing an "upgrade" (it's not really an upgrade as it just uninstalls the old version first) and clean install. 

An error pops up stating a fatal error occured and it needs to be uninstalled, rebooted and tried again. Of course this makes no difference.

This was while trying to install to the D drive. I did another uninstall, did a few reboots and tried installing to the C drive and it installed fine.

However it doesn't seem to work as I get this in the web client no matter what I try, and I don't care enough to open a support case.

Error communicating with HP's services.  Please retry after restarting HP OneView for VMware vCenter Server services.

Here is what the event viewer on mine showed for the failures. 

 

Log Name:      Application
Source:        HPOV4VCSERVER
Date:          2/22/2016 9:38:02 AM
Event ID:      11
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      servername
Description:
The description for Event ID 11 from source HPOV4VCSERVER cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

Traceback (most recent call last):
  File "win32serviceutil.pyo", line 792, in ServiceCtrlHandlerEx
  File "hpserver.pyo", line 66, in SvcStop
  File "win32serviceutil.pyo", line 768, in ReportServiceStatus
error: (6, 'SetServiceStatus', 'The handle is invalid.')

the message resource is present but the message is not found in the string/message table

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="HPOV4VCSERVER" />
    <EventID Qualifiers="49152">11</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-02-22T15:38:02.000000000Z" />
    <EventRecordID>77882</EventRecordID>
    <Channel>Application</Channel>
    <Computer>servername</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Traceback (most recent call last):
  File "win32serviceutil.pyo", line 792, in ServiceCtrlHandlerEx
  File "hpserver.pyo", line 66, in SvcStop
  File "win32serviceutil.pyo", line 768, in ReportServiceStatus
error: (6, 'SetServiceStatus', 'The handle is invalid.')</Data>
  </EventData>
</Event>

 

 

Log Name:      Application
Source:        HPOV4VCUIM
Date:          2/22/2016 9:38:02 AM
Event ID:      11
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      servername
Description:
The description for Event ID 11 from source HPOV4VCUIM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

Traceback (most recent call last):
  File "win32serviceutil.pyo", line 792, in ServiceCtrlHandlerEx
  File "hpuim.pyo", line 69, in SvcStop
  File "win32serviceutil.pyo", line 768, in ReportServiceStatus
error: (6, 'SetServiceStatus', 'The handle is invalid.')

the message resource is present but the message is not found in the string/message table

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="HPOV4VCUIM" />
    <EventID Qualifiers="49152">11</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-02-22T15:38:02.000000000Z" />
    <EventRecordID>77884</EventRecordID>
    <Channel>Application</Channel>
    <Computer>servername</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Traceback (most recent call last):
  File "win32serviceutil.pyo", line 792, in ServiceCtrlHandlerEx
  File "hpuim.pyo", line 69, in SvcStop
  File "win32serviceutil.pyo", line 768, in ReportServiceStatus
error: (6, 'SetServiceStatus', 'The handle is invalid.')</Data>
  </EventData>
</Event>