HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Issues installing HP OneView for VMware vCenter 7.6 and vSphere 6.0

DHRServerTeam
Occasional Contributor

Issues installing HP OneView for VMware vCenter 7.6 and vSphere 6.0

After installing HP OneView for VMware vCenter 7.6 I cannot get it to communicate with my vCenter Server Appliance.  When I login to my vSphere web client and try to configure the product.  I get this error message.

 

"Error establishing a connection to the vCenter to start a session.  Make sure connection to vCenter is valid."

 

However, when I login to the VMware Server Administrator Portal, my vCenter is listed correctly.

 

Am I missing something?  I have tried to uninstall the product and re-install and same issue arises. I have tried to remove the vCenter credentials and adding them again and still same issue.  I have also verified my DNS settings and A records do exist for both my VCSA and HPOV4VC server.

 

Anyone run into a similar issue?  Any ideas what or where to check?  

 

 Edit:  The plug-in seems to be working on the vSphere client but not on the web client.  I can see the vCenter credentials on the HP Management Administration page within the vSphere win32 client.  When I try to do the same on the web client, I get the error stated above. "Error establishing a connection to the vCenter to start a session.  Make sure connection to vCenter is valid."

 

Why would the plugin work in the win32 version and not the web client?

4 REPLIES
DHRServerTeam
Occasional Contributor

Re: Issues installing HP OneView for VMware vCenter 7.6 and vSphere 6.0

I have finally figured it out.  

 

In order to get the plug-in to work in my environment, I had to add all the vCenters associated with my Platform Services Controller.  Once I added my 2 vCenter server credientials to the Server Administrator portal, the vSphere web client started displaying all data correctly for the HP OneView for vCenter Plugin.  I can finally configure the plugin through the web client and no longer getting connection errors for vCenter.

 

Now I'm getting issues trying to add my 3Par storage array to the Storage Portal.  

ChrisLynchHPE
Neighborhood Moderator

Re: Issues installing HP OneView for VMware vCenter 7.6 and vSphere 6.0

When you configured the plugin, did you make sure to use the "Issued To" or what is the Common Name field of the SSL certificate of your vCenter hosts?  That is critical to the Storage plugin working.

johnhutch71
Visitor

Re: Issues installing HP OneView for VMware vCenter 7.6 and vSphere 6.0

Afternoon All,

 

I'm having a similiar problem with Onview for vCenter when using vSphere 6, it was working fine until the upgrade from 5.5 and since them I'm seeing mixed results.

 

When I try to log into the Storage Administrator portal I'm getting the following error message, I'm now using v7.7 and tested yesterday on a customer site where I did a clean install in their 5.5 ESX environment which worked fine.

 

Unable to connect to 'HP OneView for vCenter Storage Module' service. Please ensure that the service is running or restart 'HP OneView for vCenter Storage Module' service.

 

I've restarted all the services and the server but keep getting the same error message, I've even built a new server and installed but got exactly the same problem which is why I'm thinking its an ESX version related issue.

 

Help please

 

Thanks

John

 

ChrisLynchHPE
Neighborhood Moderator

Re: Issues installing HP OneView for VMware vCenter 7.6 and vSphere 6.0

Did you make sure to add the Platform Services Controller and all vCenter servers in your environment?