HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Kernel panic after 3.00.05 upgrade

JonasH
Occasional Visitor

Kernel panic after 3.00.05 upgrade

Hi

We have a problem when upgrading from 2.00.07 to 3.00.05.

After the appliance reboots during the upgrade we get kernel panic.

Any ideas on how to solve this?oneview_kernel_panic.jpg

6 REPLIES
ChrisLynchHPE
Neighborhood Moderator

Re: Kernel panic after 3.00.05 upgrade

If you have not done so already, please open a support case for this issue.

ned1313
Visitor

Re: Kernel panic after 3.00.05 upgrade

Jonas,

I am having the same thing.  Haven't had a chance to open a support ticket yet.  Did HPE support figure out what was required to fix it?

ChrisLynchHPE
Neighborhood Moderator

Re: Kernel panic after 3.00.05 upgrade

As we have not recieved any support calls or customer escalations reagrding kernal panics during upgrade, I would not say this is a known issue.  Please open a support case, and elevate it to Level 2.

ChrisLynchHPE
Neighborhood Moderator

Re: Kernel panic after 3.00.05 upgrade

Also, I'm curious to know if the virtual disk file was provisioned as a Thin Disk and if your data store ran out of disk space to increase addtional allocation.

ChrisLynchHPE
Neighborhood Moderator

Re: Kernel panic after 3.00.05 upgrade

Duing a bit more research, this is likly caused by the init.rd image not being created properly during the appliance upgrade process.  A similar VMware KB article points this out:  https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2086520

So, I would strongly suggest opening a support ticket if the appliance is still not booting due to the reported kernel panic.

dan_pa
Occasional Advisor

Re: Kernel panic after 3.00.05 upgrade

This issue is now noted by customer advisory c05359133, Engineering advisory c05358819 and only addresses what to do once the upgrade to 3.xx is started and panics. 

I have a customer that is planning the upgrade, however the check for /dev/sda1 usage is 56%, thus they may be impacted by this.  I called support for a PRE-upgrade workaround and was told there is none, a fix will be in the next version of OV.... or take my chances that this wont happen. I preferr to have the customer postpone the upgrade until the fix.  

anyone else hear anything different??