HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

OV communication to iLOs defaults to IP rather then FQDN

 
SOLVED
Go to solution
TheGord
Advisor

OV communication to iLOs defaults to IP rather then FQDN

Hello, 

We're running OV 4.20.01.01-0385523 with our iLO4 at fw 2.70 and iLO5 at 1.46.

When clicking on the links for our iLOs within OV on the server hardware page the redirect ends up going to the IP rather then the FQDN. As we don't currently put our IPs in as SANs in our certs this behaviour results in an unsecure connection.

As a test, i redid a couple of certs for iLO4 and 5 with IPs included as SAN and got the secure connection.

Is this expected behaviour in OV? Any way to change the priority?

Thanks.

G.

7 REPLIES 7
ChrisLynch
Neighborhood Moderator
Solution

Re: OV communication to iLOs defaults to IP rather then FQDN

This is expected behavior for HPE OneView 4.20 and older.  Starting wtih 5.00, if you add server hardware using the FQDN, OneView will also use it in the iLO links in the server hardware view.  Your only other option is to redo your iLO certs with the appropriate SAN values.


I am an HPE employee

Accept or Kudo

stepcz
Collector

Re: OV communication to iLOs defaults to IP rather then FQDN

Hello Chris,

In my case I observe different behaviour. Oneview v. 4.20 was using correct links to FQDN hostnames (hostname.ilo.loc which we have in internal DNS), but the 5.0 version offers links to ILO hostname without domain suffix. So I am forced to use the link with IP address anyway. 

My configuration: in Onboard admin /Enclosure bay addressing section every blade has Domain set to ilo.loc. The ILO interface Dedicated network port / General shows ilo.loc in the field Domain as expected, with Note: Domain Name is currently set through DHCP.

I tried restarting ILO, refreshing Enclosure etc. but oneview still uses only ILO hostname without domain... What can I do to force FQDN links? 

ChrisLynch
Neighborhood Moderator

Re: OV communication to iLOs defaults to IP rather then FQDN

Verify that the iLO has a configured DNS domain value set in iLO Hostname Settings when you configure the iLO Network settings.  You can verify that it is set correctly by both looking at the iLO login page, or in the upper right corner below the username for the iLO Subsystem name.


I am an HPE employee

Accept or Kudo

stepcz
Collector

Re: OV communication to iLOs defaults to IP rather then FQDN

iLO hostname settings show the correct domain name set through DHCP (from enclosure Onboard admin) and the FQDN is displayed correctly both on login screen and in the upper right corner after logging in. I even tried disabling "Use DHCPv4 Supplied Domain Name" option and entered the domain name manually (I used a different suffix just to be sure), which was correctly reflected in ILO web GUI after reset, but OV is still using only ILO hostname, not FQDN.

It is a general behaviour across all servers in both of our OV 5.00.00.02 instances. And I am pretty sure it used to work in OV 4 before the upgrade, it seems to be the new version's "feature".

ChrisLynch
Neighborhood Moderator

Re: OV communication to iLOs defaults to IP rather then FQDN

I would ask that you open a support case at this point.  That isn't the expected beahvior with 5.00.


I am an HPE employee

Accept or Kudo

stepcz
Collector

Re: OV communication to iLOs defaults to IP rather then FQDN

OK, will do. Thank you!

fojtp
New Member

Re: OV communication to iLOs defaults to IP rather then FQDN

Hi,
Did you solve it? I have the same problem.

Thank you