HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

OV4VC - WBEM Connection/Schema Problems

SOLVED
Go to solution
Edward L. Haletky
Valued Contributor

OV4VC - WBEM Connection/Schema Problems

Hello,

I have an issue where the OneView for vCenter 8.1.0 keeps giving a WBEM Connection problem. Within the logs this shows up as:

portlets.collector ERROR Error collecting server_entity for HostSystem:host-??: 404 not found

In essence the server_entity cannot login to the WBEM CIM provider as the user provided, which is specified as the root user in my case. So a few questions:

  1. Is there a default user, not documented? perhaps cimuser?
  2. Is there anyway to debug this?

I tried the curl method with the following result:

curl -ik 'https://esxi-server:5989' --request POST --data "" --basic --user root
Enter host password for user 'root':
HTTP/1.1 200 OK
Content-Type: application/xml; charset="utf-8"
Content-Length: 0
Cache-Control: no-cache
CIMOperation: MethodResponse

So I know it works, but it does not from within OV4VC.. I also enabled TRACE logging with no change in the output. At a loss here. I tried setting the per host username as well.

Further information. It looks like it may connect as expected but cannot parse the resultant schema. This is with the HPE build as the OV4VC hpcs.log has many of the following style of errors:

<string>:3005:0:ERROR:SCHEMASV:SCHEMAV_ELEMENT_CONTENT: Element '{http://hp.com/ilo/ribcl/2.23}logical_drive_type': This element is not expected. Expected is ( {http://hp.com/ilo/ribcl/2.23}physical_drive ).

Any ideas?

Edward L. Haletky

2 REPLIES
Edward L. Haletky
Valued Contributor

Re: OV4VC - WBEM Connection/Schema Problems

Hello,

More information. Due to the gen8/gen9 issues with hp-ams, I went into a node and disabled it. Then did a rediscovery. That did not work the 'server_entity' could still not be found. 

Nor do I see Memory, NICs, Smartarray status or any firmware but StoreVirtual. The bits around CIM do not seem to be working within HPE OneView for vCenter, yet HPSIM sees them just fine as does vCenter itself.

Am I missing something here?

Best regards,

Edward L. Haletky

Edward L. Haletky
Valued Contributor
Solution

Re: OV4VC - WBEM Connection/Schema Problems

Looks like OV4VC 8.2 has fixed some of these issues... waiting for it to finish discovery but it found the nodes, and at least 1 ILO, and enclosure so far.

Looking up.

 

-Edward L. Haletky