HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

OV4VC - WBEM authorization error for server

Edward L. Haletky
Valued Contributor

OV4VC - WBEM authorization error for server

Hello,

I have 3 identical ESXi 6.5A nodes. Each built from the HPE ISO with the latest HPE packages installed from Jan2017 vibsdepot (as Feb2017 has only 6.0 packages). There are no updates pending from HPE.

On 2 of my nodes, discovery cannot find the ILO. I get a 'WBEM authorization error for server message'... in essence, OV4VC cannot login to collect the information about the node and find the ILO to complete the discovery. If I associate an ILO with the node, discovery works for the most part but then I am still missing critical patch information and still get this error.

I have restarted Management Agents, I have even rebooted the nodes.

Any other suggestions?

Best regards,

Edward L. Haletky

9 REPLIES
Godosh
Occasional Visitor

Re: OV4VC - WBEM authorization error for server

I am experiencing the same issue. Still though in the "Communication Status" window it says "normal" to both elements, and in HPE Management tab it can detect every informations on the server.

RattleS
Visitor

Re: OV4VC - WBEM authorization error for server

Anyone found a solution for this? We have the same problem with a few of our ESXi hosts and we cannot find a solution for this.

peyrache
Trusted Contributor

Re: OV4VC - WBEM authorization error for server

Hello
What is ilo firmware version ? there are some know issues on ILO4
Before 2.54 version
JYP
RattleS
Visitor

Re: OV4VC - WBEM authorization error for server

Sorry, I should have been more specific about this.

We are getting the same error message, but not this doesn't seem to have anything to to with the connection to iLO as we cannot see any WBEM related issues for the iLO.

However, we are getting the same error message for the connection being used to connect to the ESX host itself.

We are running a mixture of Gen8 and Gen9 BL460c Blades and have set up the Server module credentials for ESXi and ilO with the global Device credentials. Since this would give us the mentioned errors, we have set up individual credentials just to see i this would fix the issue which it did not.

The connection status on 7/12 Blades is good, the rest is having the mentioned problem. The issue doesn't seem to be related specificly to either Gen8 or Gen9 because some work and other don't.

Really stuck here, I have created new local ESXi users with root-privilleges and tried everything all over, no luck, same result. I have also restarted the CIM-Server on all ESXi hosts, no luck either.

We are running the following configuration:

Management VM
Version 8.2.0
Release 1-20170207.204606

iLO: Mixture of 2.50 and 2.54
ESXi: VMware-ESXi-6.0.0-Update2-3620759-HPE-600.9.6.0.49-Oct2016


Any help is greatly appreciated.

See screenshots for referrence.

Thanks,
Ralph

 

peyrache
Trusted Contributor

Re: OV4VC - WBEM authorization error for server

RattleS
Visitor

Re: OV4VC - WBEM authorization error for server

From what I can read this approach requires the ESX hsot to reboot. This would need to be scheduled, so nothing which I "just can give a go".

Also, how do I need to read the SPP to VIBsdepot mapping link? Pick the lates one applicable to our ESXi release, which would be this one: ( http://vibsdepot.hpe.com/hpe/jul.18.2017/ )? Bu then on the "HP to SPP" column it tells "N/A".

So not sure which one to pick there. We are provisioning our Blades using OneView with  Service Pack for ProLiant version 2016.10.0

So does this matter which one I have to pick?

Thanks for your help

RattleS
Visitor

Re: OV4VC - WBEM authorization error for server

Alright, so we managed to get a change approved for installing updated driver VIB's and HPE mgmt VIB's on one of the affected servers since this is not a PROD system.

Quick answer: Didn't work, getting same WBEM error as before.

Long answer: I followed the following link: http://vibsdepot.hpe.com/hpe/dec2016/ since this is the latest version for the SPP we are using. I went through ALL the drivers and did a manual vib update from the esxcli, this way I would know if the new package includes drivers which are newer than the existing ones.
Out of the 23 available drivers only 1 was applicable:

root@HOST:/tmp/drivers] esxcli software vib update -d "/tmp/drivers/hpsa-6.0.0.124-offline_bundle-4683364.zip"
Installation Result
Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
Reboot Required: true
VIBs Installed: HPE_bootbank_scsi-hpsa_6.0.0.124-1OEM.600.0.0.2494585
VIBs Removed: HPE_bootbank_scsi-hpsa_6.0.0.120-1OEM.600.0.0.2494585
VIBs Skipped:
[root@HST:/tmp/drivers]

Ok, so next thing was to update the HPE MGMT Software Bundle.

Downloading all 4 .zip files:

 ams-esxi6.0-bundle-10.5.0-15.zip     14-Dec-2016 01:43  7.2M  
[   ] hpe-esxi6.0uX-bundle-2.6.0-22.zip    14-Dec-2016 01:43   11M  
[   ] hpe-HPUtil-esxi6.0-bundle-2.6-12.zip 14-Dec-2016 01:43  9.1M  
[   ] hpe-nmi-esxi6.0-bundle-2.4.16.zip    14-Dec-2016 01:43   13K  

 in this case, i forced the installation instead of checking wether the installed ones were newer. Some of the VIB's were included in multiple ZIP's wen I went through all of them trying to install. I forced it anyway just in case.
After the ESX host reboot, I still got the same error msg in regards to the WBEM, so frustrating.

OK, back to the drawing board. I followed the second link you provided for:

HPE ESXi Offline Bundle for VMware vSphere 6.0

Even tho in the SPP mapping PFD it tells me that the versio "esxi6.0uX-mgmt-bundle-3.1.0-28.zip" wouldnt be compatible with the SPP we are using I forced the install anyway:

[root@HOST:/tmp/hpe-esxi60-offline-bundle] esxcli software vib update -d "/tmp/hpe-esxi60-offline-bundle/esxi6.0uX-mgmt-bundle-3.1.0-28.zip"
Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: HPE_bootbank_amsd_600.11.1.0-24.2494585, HPE_bootbank_cru_6.0.9.8-1OEM.600.0.0.2494585, HPE_bootbank_fc-enablement_600.3.1.0.16-2494585, HPE_bootbank_ilo_600.10.1.0.12-1OEM.600.0.0.2494585, HPE_bootbank_smx-provider_600.03.12.00.17-2768847
   VIBs Removed: HPE_bootbank_amshelper_600.10.5.0-24.2494585, HPE_bootbank_hpe-cru_6.0.8.6-1OEM.600.0.0.2494585, HPE_bootbank_hpe-esxi-fc-enablement_600.2.6.20-2494585, HPE_bootbank_hpe-ilo_600.10.0.0.26-1OEM.600.0.0.2494585, HPE_bootbank_hpe-smx-provider_600.03.11.00.9-2768847
   VIBs Skipped:
[root@HOST:/tmp/hpe-esxi60-offline-bundle]

Again, giving the Host a reboot would result in the same story as before, WBEM failed to login., account locked.

Back to the drawing board I guess...

peyrache
Trusted Contributor

Re: OV4VC - WBEM authorization error for server

Shall you post ahs.log for ilo please
Thanks
JY
peyrache
Trusted Contributor

OV4VC - WBEM authorization error for server

Did you use oneview ?
Do you have any error message about certificate under oneview
Thanks
JY