HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

OneView 5.0 failing to apply firmware even it says it needs to be applied

 
Highlighted
Occasional Advisor

OneView 5.0 failing to apply firmware even it says it needs to be applied

So as we have yet another advisory about firmware which can cause crashes, QLogic in this case, I went again and built a custom SPP. As base I took Gen9/10 SPP 2019.12.0, downloaded the latest QLogic firmware, which would update the firmware package to 1.73.08. 

Update the server profile template to switch to the new custom SPP

Go to the server profile and select update from template. It updates 4 pieces of firmware, it finishes and everything is green

Power on server and it changes to yellow, saying the firmware doesn't match the baseline

Check firmware compliance, sure enough, QLogic firmware was NOT updated to the 1.73.08 which is part of the custom SPP.

Go back to server profile and select reapply, it comes back saying firmware is up to date and goes back to warning saying it isn't in compliance.

Really? And I dread calling support because 3 or 4 separate people I talked to yesterday didn't even know about this whole custom SPP building inside of OneView.

 

2 REPLIES 2
Highlighted
HPE Pro

Re: OneView 5.0 failing to apply firmware even it says it needs to be applied

Can you execute HPSUM on the server and see if HPSUM inventories the baseline components, and reports to you that the firmware does not match with what is in the baseline?  Otherwise, a support case is needed here.  Which you should ask that the support case be elevated to L2.


I am an HPE employee

Accept or Kudo

Highlighted
Occasional Advisor

Re: OneView 5.0 failing to apply firmware even it says it needs to be applied

So even this is a Gen10, OneView did tell the system to boot the SPP from OneView to apply an Intel NIC, so I interrupted that and selected manual when the SPP prompt cames up.

When it does inventory and says there are updates it does show both QLogic firmwares and has selected the correct newer one. Also support was able reproduce this in the lab now and escalated it to ERT.