HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade Path from 2.00.09 to 4.1

 
SOLVED
Go to solution
NTL_Jarrod
Occasional Visitor

Upgrade Path from 2.00.09 to 4.1

Hi,

We are currently on HP OneView firmware version 2.00.09-0305233 and we are looking to upgrade to 4.1.
As I understand it, the upgrade path is 2.00.09 -> 3.10 -> 3.10.07 -> 3.10.10 -> 4.00.07 -> 4.10.03.

I have the BIN files for 3.10.07, 3.10.10, 4.00.07 and 4.10.03, but I do not have a BIN file for 3.10 and cannot find it anywhere. 3.10 seems to only be offered on the HPE Software Depot as ESXi/HyperV/KVM files, not as BIN updates, and 2.00.09 will not accept 3.10.07 as a valid update file.

Where can I obtain the 3.10 upgrade BIN file?

Thanks,

Jarrod

4 REPLIES 4
DanCernese0
HPE Pro

Re: Upgrade Path from 2.00.09 to 4.1

All OneView versions have X.XX.XX digits.  There is only 3.10.04 and 3.10.07.  Normally you would be able to upgrade from 2.00.03 => 3.10.07 => 4.10.03, however, there was limited upgrade testing for 3.10.07 so that requires you go through 3.00.04 or 3.00.05 

I know for certain you can go directly from 3.10.07 => 4.10.03 though.

 

 


Accept or Kudo
NTL_Jarrod
Occasional Visitor

Re: Upgrade Path from 2.00.09 to 4.1

Hi,

Thank you for the prompt response. I have tried the below BIN files, all of which come back with the error "Unable to validate file." after being uploaded as part of the update process. Further inspection reveals the error "Update version check failed."

HPE_OneView_3.10.07_Update_Z7550-96417.bin
HPE_OneView_3.10.08_Update_Z7550-96481.bin
HPE_OneView_3.10.10_Update_Z7550-96515.bin

The above files were all sourced from the HPE Software Depot.

There are no earlier versions of OneView available on the Software Depot -- the only BIN file under version 3.10.07 is the version I am already on - 2.00.09. Where can I a BIN file that will get me onto 3.00.04 or later?

DanCernese0
HPE Pro
Solution

Re: Upgrade Path from 2.00.09 to 4.1

Note that 3.00 was removed because it is no longer supported and shortly 2.00 will be removed as well (it was an oversight).  If you don't have a contact with the kits, you'll have to call support and they can provide any missing hops.


Accept or Kudo
NTL_Jarrod
Occasional Visitor

Re: Upgrade Path from 2.00.09 to 4.1

Hi,

Thanks again for the prompt response. In that case, we are going to deploy a fresh VM from the 4.10 ESXi template, copy the config across, then decommission the old VM.

For anyone coming across this topic in the future, I suggest maintaining a regular update schedule for OneView, as HPE do not keep upgrade path versions readily available for download forever.