HPE OneView
cancel
Showing results for 
Search instead for 
Did you mean: 

VMware Virtual Center Appliance 6.0 with external PSC and OneView Plugin, No Web Client Object/Tab

DaveCook_ITP
Collector

VMware Virtual Center Appliance 6.0 with external PSC and OneView Plugin, No Web Client Object/Tab

I have an issue that I've been beating to death for about 3 days now.  I have a brand new installation of vSphere 6.0.0, 3825889 using External Platform Service Appliance and seperate vCenter Server Appliances.  I've built a new W2K12 R2 VM and installed HPE OneView for vCenter.  The installation went flawlessley and I entered the correct FQDN of the vCenter appliance.  I viewed the certificate and it matches my FQDN name.  The result is the plugin shows in the Win32 client as disabled (expected) but NOTHING shows in the vSphere Web Client.  I have no web clients open anywhere during the installation.  I've rebooted both the PSC and VC appliances separately to no avail.  If I look at the MOB interface, there is an Extension entry for extensionList com.hp.ov4vc.ngc.all.v6.0 but there's no HPE Tab or Object anywhere to be found.  I'm at my wits end and I need resolution ASAP. 

I've removed and added the MOB entry multiple times, I can ping and NSLOOKUP the IP and FQDN of the VC and PSC and the OV4VC guest VM every which way.  I'm running Virtual Connect 4.5 and OneView 2.00.02-0219211.  I've completely deleted ALL VMs and appliancesa and rebuilt EVERYTHING from scratch and nothing is different. 

I do see the HP OneView for VMware vCenter (with the correct FQDN for vCenter) in the Administration --> Services list but when I right click on it, the options grey out immediately.  Lastly, I always attempt to register this product with vCenter using the Administrator@vsphere.local SSO account. 

Any ideas before I start recommending Dell products?  :P

3 REPLIES
milc
Visitor

Re: VMware Virtual Center Appliance 6.0 with external PSC and OneView Plugin, No Web Client Object/T

I was in the almost exact same situation as you until just a few minutes ago. The only difference is that I'm using an internal PSC. I'm not sure exactly the solution to this is so I'm going to write all the things I did which resulted in getting it to work: 

  • Kill all the sessions for the plugin from the web client  ( vCenter Servers > vcenterFQDN > Manage > Sessions)
  • Log out from the client
  • Stop and start all HP services in the following order: hpcs, HPOV4VCDB, HPOV4VCHC, HPOV4VCSERVER, HPOV4VCUIM, HPOV4VCSTORAGE
  • SSH to the vCenter server and open a bash shell. Run the following:
    • service-control --stop --all
    • service-control --start --all
  • Login to vCenter Web Client and verify

I have a hunch that this might have something to do with the vCenter certificate.

Generious
Occasional Advisor

Re: VMware Virtual Center Appliance 6.0 with external PSC and OneView Plugin, No Web Client Object/T

Seeing the same problem as the OP here....

External PSC and two vCenter servers - plugin missing in the webclient I can  see it registered correctly in MOB.
The certificate is fine as well.

Another nail in the coffin for HP OneView afraid to say.... the overall OneView product seems to be constantly failing behind and not compatibilite with VMware external PSC solutions.

DaveCook_ITP
Collector

Re: VMware Virtual Center Appliance 6.0 with external PSC and OneView Plugin, No Web Client Object/T

Update:  I never did get this working.  I later HLinux appliance version of OneView for vCenter works fine though.