HPE OneView

add-ovbaseline - Bug in OneView 5.50? Or Powershell?

 
uzimmermann
Advisor

add-ovbaseline - Bug in OneView 5.50? Or Powershell?

Using the example for add-ovbaseline:

PS /home/uzimmermann> $HotFixFile = dir ./cp045215.exe
PS /home/uzimmermann> $CompSigFile = dir ./cp045215.compsig
PS /home/uzimmermann> Add-OVBaseline -File $HotFixFile -CompSigFile $CompSigFile

Appliance Name Owner Created Duration TaskState PercentComplete
--------- ---- ----- ------- -------- --------- ---------------
mgmt-hwr-03-a Add ulfdc 11/13/2020 9:03:36 AM 00:00:00 Completed 100

PS /home/uzimmermann> get-ovbaseline | Where-Object -Property Name -like "*U38*" | where-object -Property Version -eq 2020.10.26

Name : Online ROM Flash Component for Windows x64 - HPE Apollo 2000 Gen10/HPE ProLiant
XL170r/XL190r Gen10 (U38) Servers
State : Created
Status : OK
Version : 2020.10.26
ISOFileName : Not_Applicable
XMLKeyName : Not_Applicable
BundleSize : 0.00GB
Locations : {Internal}

Notice the size of 0.00GB? Uploading the files through GUI, while when uploaded through GUI it shows with a size of 0.01GB and is usable.

PS /home/uzimmermann> get-ovbaseline | Where-Object -Property Name -like "*U38*" | where-object -Property Version -eq 2020.10.26

Name : Online ROM Flash Component for Windows x64 - HPE Apollo 2000 Gen10/HPE ProLiant
XL170r/XL190r Gen10 (U38) Servers
State : Created
Status : OK
Version : 2020.10.26
ISOFileName : Not_Applicable
XMLKeyName : Not_Applicable
BundleSize : 0.01GB
Locations : {Internal}

Using the Linux rpm package for the same firmware via powershell, does lead to an usable package:

Name : HPE Apollo 2000 Gen10/HPE ProLiant XL170r/XL190r Gen10 (U38) Servers firmware
State : Created
Status : OK
Version : 2.40.10262020
ISOFileName : Not_Applicable
XMLKeyName : Not_Applicable
BundleSize : 0.01GB
Locations : {Internal}

Not sure if this is a OneView itself issue or Powershell. I have tried this both on Windows Server 2016 Powershell and Linux Powershell 7.0.3 and 7.1, OneView powershell version 5.30 (Linux) 5.40 (Windows) and 5.50 (Windows).

@ChrisLynch Is this a powershell issue? If so I will file a github bug.

 

3 REPLIES 3
ChrisLynch
HPE Pro

Re: add-ovbaseline - Bug in OneView 5.50? Or Powershell?

The internal Upload-File method has not changed in quite a number of major releases.  I have been able to reproduce it, but I cannot figure out what is different between the UI and the API call the PowerShell library uses.  Feel free to open an issue on the project tracker as I am trying to figure this out none-the-less.


I am an HPE employee

Accept or Kudo

ChrisLynch
HPE Pro

Re: add-ovbaseline - Bug in OneView 5.50? Or Powershell?

Also, you can shorten the call to Get-OVBaseline with:

 

Get-OVBaseline -HotfixesOnly | Where Name -like "*U38*"

 


I am an HPE employee

Accept or Kudo

ChrisLynch
HPE Pro

Re: add-ovbaseline - Bug in OneView 5.50? Or Powershell?

I found the source of the problem.  I created an issue on the tracker to follow, and will have it fixed in the next library updates that I'm trying to publish before the US holiday break.


I am an HPE employee

Accept or Kudo