HPE SimpliVity
cancel
Showing results for 
Search instead for 
Did you mean: 

Arbiter and Plugin backwards compatible?

 
SOLVED
Go to solution
Randolfini
Advisor

Arbiter and Plugin backwards compatible?

I have legacy Cisco Omnistack nodes running 3.7.10 U1 and I added a new cluster of HPE DL380 G10 nodes at the same software level. Now I am going to upgrade just this new cluster to 4.0.1 U1, clearly to do so I'll have to upgrade the arbiter and plugin. Are these backwards compatible to still run with the existing legacy cluster?

HPE SimpliVity OmniStack Interoperability Guide 4.0.1U1 page 26 lists the below, so it is a supported position.

Going forward from 3.7.10U1, cluster commit allows some clusters to stay at the current release while others are upgraded to a later release

Thanks!

3 REPLIES 3
Imobi
Occasional Advisor
Solution

Re: Arbiter and Plugin backwards compatible?

Greetings!!

As you are upgrading the HPE  SimpliVity DL380 Gen 10 nodes (New Cluster only) to version 4.0.1U1, while the current  Federation version is at 3.7.10U1, you will require to upgrade the Arbiter and the Plugin accordingly as to match with 4.0.1U1. You will still be able to manage the  3.7.10U1  with the Upgraded Plugin.

Hope it answers your concern.

Thanks

Imobi

 

 

 

 

I am a HPE Employee
Deepak_K
Advisor

Re: Arbiter and Plugin backwards compatible?

Hi,

1. SimpliVity Plug-In

As per 4.0.1U1 administration guide(Refer Page no: 22):

https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=a00107306en_us

Actions in a federation that uses mixed versons of the HPE OmniStack software:

A mixture of software versions in a federation can affect access to some actions in the HPE SimpliVity Plug-in for vSphere Client:

If you are using the most recent version of the HPE SimpliVity Plug-in but all of the clusters are using an olderversion, some actions might not be supported or actions might not work as expected.To be able to use all actions, upgrade the clusters to a more recent version of the HPE OmniStack software.

Some actions are supported only on clusters that use a specific version of the HPE OmniStack software.To use these actions on a specific cluster, upgrade it to a more recent version of the HPE OmniStack software.For details about new features for a specific release, see the HPE OmniStack Release Notes for the versionsyou are using.

If the HPE SimpliVity Plug-in is configured to use a Virtual Controller that has an older version of the software,some actions might not be available.To use the action on a specific cluster, ensure that the HPE SimpliVity Plug-in for vSphere Client is configuredto use a Virtual Controller that has a more recent version of the software.

2. Ariber:

As per 4.0.1U1 Deployment Guide ( Refer page no: 15), the Arbiter is backward compatible

" This version of the Arbiter supports clusters with hosts that use HPE OmniStack 3.7.8 or later "

Regards,

Deepak

Hewlett Packard Enterprise


I work for HPE
Randolfini
Advisor

Re: Arbiter and Plugin backwards compatible?

Deepak, thanks for the detailed response with supporting documentation.