HPE SimpliVity

Arbiter installation fails - Installation Wizard ended Prematurely

 
SapnaRai
Occasional Visitor

Arbiter installation fails - Installation Wizard ended Prematurely

The Machine which had vCenter and Arbiter , Crashed. Vcenter was reinstalled successfully on the same machine, but Arbiter installation failed with the error message " HPE Simplivity Arbiter Set up Wizard ended Prematurely because of an Error "

Checked the installation log shows

req -new -nodes -batch -config "C:\Program Files\SimpliVity\SimpliVity Arbiter\\scripts\ssltmp.conf" -newkey rsa:2048 -keyout "C:\Program Files\SimpliVity\SimpliVity Arbiter\var\svtfs\0\myconf\static\node.key" -out "C:\Program Files\SimpliVity\SimpliVity Arbiter\var\svtfs\0\myconf\static\node.csr" -subj /CN=VCENTER.ASSURANCE.LOCAL -days 1095 -sha256

WARNING: can't open config file: C:\jenkins\workspace\openssl-fips-omni3p\PLAT\windows_2016_x64\build\Static\Release\openssl-install/ssl/openssl.cnf

Generating a 2048 bit RSA private key

.................+++

....+++

C:\Program Files\SimpliVity\SimpliVity Arbiter\var\svtfs\0\myconf\static\node.key: Permission denied

unable to write 'random state'

writing new private key to 'C:\Program Files\SimpliVity\SimpliVity Arbiter\var\svtfs\0\myconf\static\node.key'

21184:error:02001005:system library:fopen:Input/output error:.\crypto\bio\bss_file.c:402:fopen('C:\Program Files\SimpliVity\SimpliVity Arbiter\var\svtfs\0\myconf\static\node.key','wb')

21184:error:20074002:BIO routines:FILE_CTRL:system lib:.\crypto\bio\bss_file.c:404:

 

 

 

 

I first attempted to update the idenity store

dsv-identitystore-init “administrator@vsphere.local “  < ESXiHost IP address of corresponding OVC> root

 

Ran this command. Now, the Arbiter service is seen under services.msc   But svt-federation-show still shows Arbiter Disconnected  

So, ran the command below

dsv-arbiter-instance-set --address IP --cluster "Clustername"

 

svt-federation-show  , now shows the Arbiter connected.

3 REPLIES 3
DeclanOR
Respected Contributor

Re: Arbiter installation fails - Installation Wizard ended Prematurely

Hi @SapnaRai 

Thanks for the information.

I take it this is purely informational right, in case anybody else comes across similar.

You seem to have resolved the issue correct?

Thanks,

DeclanOR

Accept or Kudo



B0ris
Frequent Advisor

Re: Arbiter installation fails - Installation Wizard ended Prematurely

I had a similar problem and I just run Arbiter installation packet "As Administrator" and it worked.

DeclanOR
Respected Contributor

Re: Arbiter installation fails - Installation Wizard ended Prematurely

Hi @B0ris @SapnaRai 

Similar issue may happen due to compatability.

Right click the .exe file,

- properties

- compatibility

- compatibility mode

- select tickbox to run in compatibiity mode for previous versions of windows

Accept or Kudo