HPE SimpliVity
cancel
Showing results for 
Search instead for 
Did you mean: 

Simplivity 3.7.9 deployment manager test failure

 
Highlighted
VA_Rich
Occasional Advisor

Simplivity 3.7.9 deployment manager test failure

I am attempting to deploy a simplivity host to be the 2nd host in a federation and cluster.  Version of Simplivity is 3.7.9.  At the beginning of the Test Host Settings portion of Deployment Manager, I am getting an error:  Cluster Network Specification Retrieval.  Status: Failed.  Summary:  Failed to retrieve network specifications for cluster <our cluster name>.  

I have no idea what is causing this.  Has anyone else seen this?  Any ideas or suggestions as to how to remedy this error?  I really need to get this 2nd node deployed asap.  Thanks for any help and suggestions. 

10 REPLIES 10
gustenar
HPE Pro

Re: Simplivity 3.7.9 deployment manager test failure

Do you have distributed switches only in that cluster? This will occur if there are no standard switches configured. 

 

I am an HPE employee
Accept or Kudo
VA_Rich
Occasional Advisor

Re: Simplivity 3.7.9 deployment manager test failure

Actually, I don't have any distributed switches.  Only standard switches

VA_Rich
Occasional Advisor

Re: Simplivity 3.7.9 deployment manager test failure

Looking through the deployment manager logs, I've found the following:

Previously Deployed Hosts
2019-12-10 17:40:56,541Z ERROR main [c.s.d.v.NetworkPortAccessValidator] logValidationSummary(AbstractValidator.java:365) - ClusterHostsMTUConsistencyValidator: Previously Deployed Hosts is blocked by the following failed prerequisites:
2019-12-10 17:40:56,541Z ERROR main [c.s.d.v.NetworkPortAccessValidator] logValidationSummary(AbstractValidator.java:365) - ClusterHostsMTUConsistencyValidator:  + Cluster Network Specification Retrieval
2019-12-10 17:40:56,546Z DEBUG main [c.s.d.v.NetworkPortAccessValidator] executeTestPlan(ValidationExecutor.java:37) - Previously Deployed Virtual Controllers
2019-12-10 17:40:56,547Z ERROR main [c.s.d.v.NetworkPortAccessValidator] logValidationSummary(AbstractValidator.java:365) - ClusterOVCsMTUConsistencyValidator: Previously Deployed Virtual Controllers is blocked by the following failed prerequisites:
2019-12-10 17:40:56,548Z ERROR main [c.s.d.v.NetworkPortAccessValidator] logValidationSummary(AbstractValidator.java:365) - ClusterOVCsMTUConsistencyValidator:  + Cluster Network Specification Retrieval
2019-12-10 17:40:56,554Z INFO  main [c.s.d.v.NetworkPortAccessValidator] logValidationSummary(AbstractValidator.java:365) - ClusterMTUConsistencyValidationAggregator: Skipped MTU consistency test for previously deployed hosts and Virtual Controllers.
2019-12-10 17:40:56,557Z DEBUG main [c.s.d.v.NetworkPortAccessValidator] executeTestPlan(ValidationExecutor.java:37) - NIC Speed Consistency for Previously Deployed Hosts Test
2019-12-10 17:40:56,557Z ERROR main [c.s.d.v.NetworkPortAccessValidator] logValidationSummary(AbstractValidator.java:365) - ClusterHostsNICConsistencyValidator: NIC Speed Consistency for Previously Deployed Hosts Test is blocked by the following failed prerequisites:
2019-12-10 17:40:56,557Z ERROR main [c.s.d.v.NetworkPortAccessValidator] logValidationSummary(AbstractValidator.java:365) - ClusterHostsNICConsistencyValidator:  + Cluster Network Specification Retrieval
2019-12-10 17:40:56,557Z DEBUG main [c.s.d.v.NetworkPortAccessValidator] executeTestPlan(ValidationAggregator.java:174) - Host 2M2931052Q

 

So it appears Deployment Manager is attempting to find the MTU of the previously deploy Simplivity host, but for some reason it cannot.  The message is stating blocked, but both hosts are on the same subnet and there are no firewalls, etc. between them.  Any ideas, etc.?

gustenar
HPE Pro

Re: Simplivity 3.7.9 deployment manager test failure

I think the MTU test is not even starting because it can't retrieve the cluster's config. What NIC card is being used for the deployment? 

I am an HPE employee
Accept or Kudo
VA_Rich
Occasional Advisor

Re: Simplivity 3.7.9 deployment manager test failure

We are using an HPE Eth 10/25 GB 2 port 640SFP28 adapter.  Simplivity version 3.7.9

VA_Rich
Occasional Advisor

Re: Simplivity 3.7.9 deployment manager test failure

Sorry, I forgot to add the cluster has only one node deployed at this time.  The node I'm trying to deploy would be the 2nd node.  Don't think that makes a difference....

VA_Rich
Occasional Advisor

Re: Simplivity 3.7.9 deployment manager test failure

And firmware version for the NICs is 14.23.8036

policeman51
Advisor

Re: Simplivity 3.7.9 deployment manager test failure

I'm following this as well.

I'm working with the Deployment Team and we are running into the same issue on a single node deploying 3.7.6

DaveOb
HPE Pro

Re: Simplivity 3.7.9 deployment manager test failure

Is the physical network consistent? 

You could try swapping the physical cables from the deployed node at the server side to the non deployed node.

Are you using a 25 or a 10  physical network.if so are the sfps the same.ie your using all 25gb sfps.Is there something like autonegotiate set on one switch and not on the other?

If you are confident that the physical network is the same then the tests can be bypassed but you will need to compare post deploy,

 

path names many change depending on version.

C:\Program Files (x86)\SimpliVity\DeploymentManager

 

Find and edit “Simplivity.DM.View.exe.config” XML file

 

Under “<appSettings>” find the following line

 

<add key=”PredeployValidationOverride” value=”False”/>

With:

<add key=”PredeployValidationOverride” value=”True”/>

 

 

 


I am an HPE employee
Accept or Kudo