HPE Storage Networking - Switches

Re: Brocade FW Upgrade

 
Samarendra Singh_1
Occasional Advisor

Brocade FW Upgrade

Hi,

We have Sun Systems connected to SAN & XP 1024.We have Brocade 3800 Switches.All sun systems have JNI HBA (FC-6460) and all are having dual path connectivity.
We had performed Firmware Upgrade on Brocade 3800 switches from Version 3.0.2b to 3.0.2.k few days back.During the FW Upgrade activity 4 of our system gave panic error & went to Single Error mode.The act log shows JNIC Mutex Dead Lock Error.
Can any one help how this can happen if we have dual paths fully functional.
Is it related to JNI driver ( We are using version 5.1.1)

Regards,

sam
SAM
11 REPLIES 11
Eugeny Brychkov
Honored Contributor

Re: Brocade FW Upgrade

Sam,
it's very good that systems have dual paths to disks. But did you check if failover works?
Test the following: pick one server (test server) and disconnect one HBA by FC cable from the switch. Will system crash? Watch system log to see if it will log 'failing over alternative path' or something like this. Then plug this cable back, wait a little and try the same with another HBA and cable.
If system will be crashing then failover does not work and you need to deep into Sun drivers/configuration to fix it
Eugeny
Samarendra Singh_1
Occasional Advisor

Re: Brocade FW Upgrade

Hi,

DMP works perfectlly fine on all the systems and we have tested it also.10 days before we had done Firmware Upgrade on XP 1024 Box and at that moment all went fine.Befor upgrading Broacde FW we had checked the dual path status on each system and on all the systems we found that it was enabled and functional and we proceeded with FW Upgrade.

/var/adm/messages shows that the systems got panic when the the Link Came Up.And all the error threads are related to jni.

Regards,

Sam
SAM
Eugeny Brychkov
Honored Contributor

Re: Brocade FW Upgrade

Sam,
very good. After firmware upgrade server does cold reboot. Proceed with another test: turn off one switch, wait for 5 minutes and turn it on. Did you test this scenario?
Eugeny
Samarendra Singh_1
Occasional Advisor

Re: Brocade FW Upgrade

Hi,

If after FW Upgrade the system does a cold reboot then all the systems connected to SAN should have rebboted which was not the case.Instead few systems show panic and went to Single User mode.
If reboot is normal then there is no point in having Dual Path as evry time one path fsails the system will reboot.We have tested with switching off one of the switches but none of the systems went down at that moment.

Regards,

Sam
SAM
Sunil Sharma_1
Honored Contributor

Re: Brocade FW Upgrade

Hi SAM,

What is the version of HBA Firmware ?

Sunil Sharma
*** Dream as if you'll live forever. Live as if you'll die today ***
Eugeny Brychkov
Honored Contributor

Re: Brocade FW Upgrade

Sam,
sorry I wrote it incorrectly... In previous post read as "when you do FC switch firmware upgrade after it switch (not server of course) does cold reboot to load new firmware image".
Generally, in any device when you do firmware upgrade, after firmware got loaded this device should do cold reboot to load and start new firmware image
Eugeny
John Tyler
Advisor

Re: Brocade FW Upgrade

Sam,

You can contact JNI support since the adapters come with 2 yr warranty and they are pretty good in responding.. The latest driver is 5.2.1 for 6460.

Are both JNIs connected to a single fabric?
Or is it seperate fabric/switch for each path?

John.
Zeev Schultz
Honored Contributor

Re: Brocade FW Upgrade

Sam,
See these (release notes) for jni fc-6460 5.1.1
and 5.2.1 here:

http://www.jni.com/Drivers/drivers3.cfm?ID=18&OSID=8

From 5.2.1 JNI driver issues:

If you are using the Brocade 3800 switch in a 2 Gb mode, you must force the HBA to be a Public Loop device. This applies only to the
FCE-6460, FCC-6460, FCE-1473, and FCE2-1473 HBAs when operating in 2 GB mode.

I would also scroll www.brocade.com for known
issues with 3800 firmwares.

God bless Google :)

Zeev
So computers don't think yet. At least not chess computers. - Seymour Cray
Zeev Schultz
Honored Contributor

Re: Brocade FW Upgrade

Definetelly go to brocade.com,see fabric support matrix for jni fc-6460 & 3800 and see
that FOS v. is 3.0.2c and not 3.0.2k which may be is the troublemaker.

Regards

Zeev
So computers don't think yet. At least not chess computers. - Seymour Cray