HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

HPVSA driver downgrade on VMware

stomko
Occasional Contributor

HPVSA driver downgrade on VMware

A customer experienced major problems in Vmware configured with VSA. We then downgraded the HPVSA driver to version x.x.x-88, which solved the problem. However, this document is old and provides only a workaround, not solution. Is there a newer version of this driver available, where this bug is fixed?

http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=c05026755

How did we receive the failed driver in a first place? Was it part of some VMware upgrade bundle that was installed?

-Sto

1 REPLY
Stor_Mort
HPE Pro

Re: HPVSA driver downgrade on VMware

Hi Sto,

The VMware hpvsa driver is not actually part of the StoreVirtual software suite. It is the HP(E) Virtual Smart Array driver which is used for some types of raid controller such as the B120i and B320i. The StoreVirtual VSA interacts with the VMware storage API, not the hpvsa driver.

In the Jan 27 2017 vibsdepot recipe, HPE is recommending scsi-hpvsa-5.5.0.100-1 at this URL:

http://vibsdepot.hpe.com/hpe/oct2016/esxi-550-devicedrivers/hpvsa-5.5.0.100-1.zip

If this is for the B320i Smart Array controller, update the firmware to 15.10.09.001 from the SPP 2016.10.0 or later.

In most StoreVirtual VSA installations, we recommend a higher performance Smart Array controller such as P420 with 2GB battery-backed-up cache for best performance. These raid controllers use the scsi-hpsa driver.

I am an HPE employee - HPE StoreVirtual Support