Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

Hyper-V 2012R2 and CSVs volumes remain in re-directed state after path failure is re-established

ALgon
Advisor

Hyper-V 2012R2 and CSVs volumes remain in re-directed state after path failure is re-established

Hello,

 

We have the following setup:

 

A multisite 8 node P4500 cluster running StoreVirtual 12.5 connected at 10Gbps - 4 nodes at each site

A 4 node Hyper-V 2012 R2 cluster with two HP DL380 G7 - 2 servers at each site.

Each Hyper-v host has a 4 NICS - Two for ISCSI and another two for a converged Hyper-V network setup (Live Migration, Cluster\CSV and management and Hyper-V VMS)  

HP DSM for MPIO is installed and set to use Round Robin

We have created about 8 RAID-10 CSV volumes for the Hyper-V cluster

We are currently running some basic failover and redundancy tests before going live with the setup.

One of these tests involves disconnecting both ISCSI links from a host - We just shut down the switch ports to simulate this test. 

What should happen is when the links fail, the host should re-direct the ISCSI storage traffic via the CSV network to another host that still has a connection to the storage. 

This does indeed happen, but when we reconnect the failed ISCSI NICS, the CSV volumes should come out of redirected mode and the host should stop redirecting ISCSI traffic.

However, this is not the case.  Instead, only some ISCSI sessions are re-established and so some of the CSVs remain in a redirected state for this host. I can see this by running the mpclaim commands and only the CSVs not in re-directed mode have sessions going to them.

If I open the ISCSI initiator on the host, all the volumes display as connected but when I select one of the volumes that's still in the re-directed state, I'm unable to select the MPIO button to check the load balancing method, because it's greyed out. 

The only way to resolve this and fully re-establish the connections is to reboot the host. 

Has anyone seen this and is this normal?

Thanks in advance