HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

LH P4500 nodes will not accept patches

HP_hardware
Occasional Advisor

LH P4500 nodes will not accept patches

P4500 iSCSI solution package (ATA011A).  CMC version 10.5.00 (Build 0181.0) is running on SLES 10.4

Since the last patching, about two months ago, CMC reports new patches available but when downloaded and applied, only the CMC updates.  Attempting to update the nodes results in "Installation failed.  There was an error in the script or package. (Exit Status 4)."  Today CMC again reported new patches available, CMC updated just fine but still getting the above error when I try to update the nodes.  Relevant detail info on the failure message is:

**********************

Performance Instrumentation -- Upgrade:  --End Of MG Configuration--


/192.168.10.202:11120: connectToServer received a Status message from the install server running on

the node It was: 'OK', and the error flag was: false


/192.168.10.202:11120: sendPackageToServer received a Status message from the install server running

on the node It was: 'OK', and the error flag was: false


/192.168.10.202:11120: Received an UpgradeScriptStatus message from the install server running on the

node It was : Extracting the install file ...


/192.168.10.202:11120: Received an UpgradeScriptStatus message from the install server running on the

node It was : Preparing for installation of patch 10144-00 ... (Wed Jun 19 19:22:42 GMT 2013)

/192.168.10.202:11120: Received an UpgradeScriptStatus message from the install server running on the

node It was : ERROR: This patch is not meant for the HP_DL18X platform


/192.168.10.202:11120: Received an UpgradeScriptStatus message from the install server running on the

node It was : ERROR: Dependency check failed.


/192.168.10.202:11120: Received an UpgradeScriptStatus message from the install server running on the

node It was : Installation of patch 10144-00 was aborted due to an error. (Wed Jun 19 19:22:43 GMT

2013)


/192.168.10.202:11120: Received an UpgradeScriptStatus message from the install server running on the

node It was : Contact Customer Support at http://www.itrc.hp.com


/192.168.10.202:11120: Received an UpgradeServerStatus message from the install server running on the

node It was : INSTALL_STATUS_MESSAGE: done [4]

**********************

 

So my questions are:

1:  IF this patch is not intended for my nodes why did CMC download it and indicate it should be installed?

2.  Today marks the second time I have tried to patch, with the same error results shown above.  Will there be a future node patch that will actually apply, or is somthing messed up with my current config and causing the update issue?

 

Thank you,

 

DG

 

6 REPLIES
Emilo
Trusted Contributor

Re: LH P4500 nodes will not accept patches

Hello,

Preparing for installation of patch 10144-00 it the message you get before it fails.

Does that patch show up in the patch list of any of the nodes in your cluster?
According to my notes that patch is for the following "drive firmware patch (critical) needed for drive models EF0300FATFD, EF0450FATFE, and EF0600FATFF"  do you have those drives?

 

If so @ what version??

 

 

HP_hardware
Occasional Advisor

Re: LH P4500 nodes will not accept patches

Thank you for your reply.

Under "Diagnostics" I do not see 10144-00 listed for any node.  I do have one node with one EF0450FATFE drive.  That drive is serial#J1V11BEN and shows firmware version HPD7.

Emilo
Trusted Contributor

Re: LH P4500 nodes will not accept patches

Just do the fimware upgrade on that node.

Oh by the way is that the node that is failing?

You could also just try upgrading that node "alone" you have to hack the preferences.txt file

Just do a search on how to that in this fourm.

If you cant find it let me know and I will post the intructions.

 

HP_hardware
Occasional Advisor

Re: LH P4500 nodes will not accept patches

I haven't been able to find info in the form on modifying the preferences.txt file.  Node 2 is the node with the drive needing the upgrade, but the installation is failing as it tried to do Node 1 first--so your suggestion of upgrading only that note seems spot-on, but some insight into hacking the preferences file would be helpful.

Thanks,

 

DG

 

Emilo
Trusted Contributor

Re: LH P4500 nodes will not accept patches

The following steps will enable Support Upgrades in the CMC, and will allow you to manually patch the storage systems with individual patches:

1. Shutdown the CMC

2. Open \Users\[user]\.storage_system\preferences.txt

3. At the top of the file, add the following:

CmcSystemPreference.supportMode=true
CmcUpgradePreference.useOldUpgrades=true
CmcUpgradePreference.userUpgrade=true

4. Start CMC, under Configuration Summary there will now be a “Support Upgrades” tab.

It is important to add the lines to the top in step 3, otherwise the “Support Uprades” tab will not be available.

HP_hardware
Occasional Advisor

Re: LH P4500 nodes will not accept patches

Ahhh, my CMC is running on Linux so I'm not finding a preferences.txt file.  Linux equivalent??

 

Thx,

 

DeVern