HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

Node Network Utilization

Steve McGee
Occasional Advisor

Node Network Utilization

I have a 2 node cluster with both gb NICs on each node spread across 2 stacked extreme x450e switches. I have been monitoring my throughput utilization of the two NICs on each node and noticed that node 1 will appear to have near equal utilization on both NIC ports, while node 2 appears to have one nic port with similar utilization as node 1, but the second nic port will have next to 0 utilization.

Has anyone seen this before?

I'm using ALB load balancing on both nodes.
4 REPLIES
Bryan McMullan
Trusted Contributor

Re: Node Network Utilization

Is Node 1 the VIP? If so, that may be the reason for the increased traffic. There is additional traffic overhead for the VIP.

Are you using MPIO?
Steve McGee
Occasional Advisor

Re: Node Network Utilization

I am using MPIO, but with VIP that doesn't matter does it?

If during heavy SAN disk access I'm seeing 30% on three of the four NICs it leads me to think that things aren't operating properly.

I can't say that I'm experiencing any issues, but I've not been a lefthand user but for a few months, so I'm not qualified to make that assumption yet :).
Bryan McMullan
Trusted Contributor

Re: Node Network Utilization

ALB does not equate to fully balanced on each NIC. There are times when we have no traffic on one NIC and a bit on the other.

Try to fail the active NIC on node 2. If everything continues to work as expected, it is just the load balancing algorithm.
Steve McGee
Occasional Advisor

Re: Node Network Utilization

I actually have already performed that procedure and everything appeared to function properly.

Thanks for the clarification.