Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

P4000 VSA's stuck at 90% memory utilization

SOLVED
Go to solution
fourg
Advisor

P4000 VSA's stuck at 90% memory utilization

Currently have a two node cluster running P4000 VSA's which recently I cannot get the high memory utilization down less than 90%.  These two are used exclusively as a location for remote snapshots from our production clusters.  During the day there is near no activity, however the memory for both of these stayed pegged according to CMC.  If I look at the VSA VM's in VMware vCenter it shows each only have a few hundred megabytes of active memory, while they are each allocated 8GB.  I've tried rebooting the VSA's, but no luck, the high memory remains.  Any ideas?

4 REPLIES
oikjn
Honored Contributor
Solution

Re: P4000 VSA's stuck at 90% memory utilization

add more memory.  The VSA "uses" memory based on the size of the disks presented to it.  I put uses in quoes because as you see it doesn't always make use of it, but it does always allocate it so its available should it be needed.  There is nothing you can do...  add more memory... its usually a very cheap upgrade.

fourg
Advisor

Re: P4000 VSA's stuck at 90% memory utilization

Thanks @oikjn. I've bumped up the VSA VM memory from 8GB to 12GB and the 90% utliziation has dropped to 60%.  Will continue to monitor to see if it creeps back up.

oikjn
Honored Contributor

Re: P4000 VSA's stuck at 90% memory utilization

Not sure your storage size per VM, but just follow the suggestion in the VSA guides for memory size.  I can't remember if the memory spikes during snapshot creation or not, but maybe monitor it and see if it does.  I used to monitor it and found it literally NEVER moved so I brought the memory utilization to ~80% and have left my VSA nodes at that and nothing has complained and performance hasn't changed.  Short story...  you can probably get away with 10GB if you wanted that 2GB back and MAYBE 9GB if you need that extra little bit as well.

fourg
Advisor

Re: P4000 VSA's stuck at 90% memory utilization

This two node cluster is serving up about 40TB of usable space.  Monitoring performance I notice also that the memory usage never changes for either VSA, they appear to have what they need reserved at all times.  I thought about going from just 8GB to 10GB for each, but wasn't an issue to go to 12GB so went ahead with it.

 

Thanks