HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

P4500 Windows 2008 R2 Cluster

SOLVED
Go to solution
bruce24
Occasional Contributor

P4500 Windows 2008 R2 Cluster

I'm experiencing the following issue: we just setup (2) p4500 in a cluster and we're testing the failover capabilities of the ISCSI NICS on a Windows R2 2008 Cluster Servers. Each ISCSI NIC is cabled to a separate switch and each p4500 ISCSI port is cable to separate switches. We’re using the HP DSM on the Windows 2008 server which is set to “vendor specific” active/standby. When testing an iscsi nic failure during heavy I/O on the primary cluster node, instead of moving the I/O to the other nic, on the same node, the cluster detects this as a complete failure and does a failover of the cluster resource to the passive node during the timeout. Is there a setting that will fix this problem during the timeout delay? Thank you.
4 REPLIES
chal_1
Occasional Advisor
Solution

Re: P4500 Windows 2008 R2 Cluster

Have you set the iSCSI timeout as recommended by HP;

â ¢ Default Initiator timeout (60 seconds) is too short; can result in potential connectivity loss for pending I/O operations

â ¢ Edit Registry to change the MaxRequestHoldTime value:
â Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
â Type Ctrl-F to search for MaxRequestHoldTime
â Be sure to find the one under CurrentControlSet
â Change MaxRequestHoldTime value to 600 decimal

â Reboot system to ensure new value takes effect

â ¢ Microsoft DSM sets a timeout of 30 seconds; do not install, or uninstall if it is already installed
â ¢ After installing/upgrading iSCSI Initiator, always confirm that the MaxRequestHoldTime value is still 600
Bryan McMullan
Trusted Contributor

Re: P4500 Windows 2008 R2 Cluster

There was also an MPIO patch for Win 2k8 R2 that may help. KB979711

I believe it is part of SP1, but just in case you are missing it.

What version of SAN/iQ are you running? If it's < 9.0, there's a patch applicable to cluster environments. The one for 8.5 is 10085-00.

bruce24
Occasional Contributor

Re: P4500 Windows 2008 R2 Cluster

Thanks, I'll give it a try and see how it works out.
Alex Ball
Occasional Advisor

Re: P4500 Windows 2008 R2 Cluster

I also have a Windows 2008 R2 (Sp1) cluster with MPIO configured. If I disable one of the nics the MPIO doesn't switch the I/O to the other Nic, instead it just looses connectivity. In the end I teamed my iSCSI nics. this is acceptable with a 10GB network, but not what I would want from a 1GB network.