Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

StoreVirtual VSA Installer for KVM 12.6 fails on CentOS 7

conXO
Advisor

StoreVirtual VSA Installer for KVM 12.6 fails on CentOS 7

I am trying to do a testinstall of StoreVirtual VSA (following "HPE StoreVirtual Storage VSA Installation and Configuration Guide" rev. 10) on a Fujitsu Primergy RX100 S7, but it fails with the error below.

The VM gets created and started, but the storage dsik is not created, and when I connect to the console the network is disabled.

Is anyone using HPE VSA with CentOS 7 KVM?

When the installation guide says supported on: "CentOS 6.6, 6.7, 7.0", does that mean you cannot use CentOS 7.2?

This is the output from the installer:

Command-line arguments:  ./StoreVirtual_VSA_Installer_for_KVM_12.6.00.0155_01 -no-prompt -debug dhcp-input.json KVM-VSA-12.6.00.0155_01.img

Environment validated.
Here's the configuration summary of the VSA to be deployed:
Host Name:              VSA1
OS Image Storage Pool:  vm-storage
Personality:            VSA
SANiQ_Preferred:        0
NIC 1:                  Virtual Network: default, DHCP
Disk 1:                 Location: vm-storage, Size: 100G

User Inputs validated.
Total usable memory is 15861 MB and total ununsed memory is 8331 MB.
Memory required for a disk capacity of 100 GB is 4096 MB.
2 CPUs are required for a disk capacity of 100 GB.
Copying VSA image to /data/pools/vm-storage/VSA1.img.  This may take a few minutes.
Command used to install the VM: virt-install --name VSA1 --ram 4096 --vcpus 2 
--disk path=/data/pools/vm-storage/VSA1.img,bus=virtio --import --noautoconsole --autostart
--network network:default,model=virtio --debug Created KVM Guest VSA1. Created configuration disk image config.img in storage pool vm-storage. RedHat OS not found. LSB Version: :core-4.1-amd64:core-4.1-noarch Distributor ID: CentOS Description: CentOS Linux release 7.2.1511 (Core) Release: 7.2.1511 Codename: Core . In InstallVm needDevice set to false. Here's the output from LOSETUP: /dev/loop0 Mounted /data/pools/vm-storage/config.img as a loopback device /dev/loop0 to /mnt/image. Created configuration file /mnt/image/config.vsa on /mnt/image. Unmounted filesystem on /mnt/image and detached the loopback device /dev/loop0. Err:<nil>. Unable to attach disk /data/pools/vm-storage/config.img as target sda to VM VSA1. Err: exit status 1: error: Failed to attach disk error: internal error: Could not find scsi controller with index 0 required for device

Regards
Kristian

2 REPLIES
Xubc
Occasional Visitor

Re: StoreVirtual VSA Installer for KVM 12.6 fails on CentOS 7

The same error occured in my installing process. I use centos7.1.

Stor_Mort
HPE Pro

Re: StoreVirtual VSA Installer for KVM 12.6 fails on CentOS 7

The StoreVirtual VSA 12.6 was tested with CentOS 6.6, 6.7, 7.0, RHEL 6.6, 6.7, 7.0 and Ubuntu 14.04 when it was released. Newer versions of CentOS, RHEL and Ubuntu were not available at that time. We continue to support the VSA in KVM and it is likely that newer host versions will be suported in the next release.

I am an HPE employee - HPE StoreVirtual Support