HPE StoreVirtual Storage / LeftHand
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade to v10 - problem to detect v9.5 node

SOLVED
Go to solution
hwelvaar
Occasional Advisor

Upgrade to v10 - problem to detect v9.5 node

Hi all, Today I performed an ugrade from v9.5 to v.10 on two LeftHand clusters, each setup in a similar way, each with 3 nodes. I've done upgades before at other customer sites, without problems. I thought the upgrade went well also today, because the GUI wizard for the update process did not report any problem, and it finished with success, and afterwards the "check for updates" reported "your software is up to date." BUT then I noticed that 2 nodes are still at v9.5, and four other nodes are now at v10. So I have 1 cluster operating at v10 (with 3 nodes in v10), and 1 clustet operating at v9.5 (with 1 node in v10, and 2 nodes in v9.5) But I can't update those 2 nodes via the CMC GUI. The CMC "thinks" that my software/version is up to date ? Anybody any ideas please? Thanks!
6 REPLIES
hwelvaar
Occasional Advisor

Re: Upgrade to v10 - problem to detect v9.5 nodeI

I must add this info: the nodes that did successfully uograde are P4300 G2 nodes. The nodes that did not upgrade are P4300 G1 nodes. Possibly this is related to the problem?
KurtG
Regular Advisor

Re: Upgrade to v10 - problem to detect v9.5 nodeI

G1 does not support v10 of SanIQ.

 

So youre systemes is now upgraded to lates possible version. :-)

 

KurtG

hwelvaar
Occasional Advisor

Re: Upgrade to v10 - problem to detect v9.5 nodeI

Very uncool ! Now my snapshot replication between these clusters does not work anymore, because they are not operating at the same SAN IQ version, and I cannot upgrade them to the same version !?!
hwelvaar
Occasional Advisor
Solution

Re: Upgrade to v10 - problem to detect v9.5 nodeI

I found a patch that you can install to enable cross-version snapshot replication. So this has solved my problem. Google for patch 10059-06 -- Patch 10059-06 -- Cross-Version Remote Copy --
Bob Firek
Regular Advisor

Re: Upgrade to v10 - problem to detect v9.5 nodeI

KurtG,

 

I'm in the same boat as hwelvaar. I have two P4300 G1, two P4300 G2, and two P4500G2 in the same cluster. I upgraded all the nodes yesterday to the latest version and noticed on the Registration tab it says "Management group version is 9.5.00, Manager auto upgrade is on.  The four storage system that are G2 upgraded to version 10.5.00.0149.0 and the two G1 server upgraded to 9.5.00.1215.0. Will I be stuck at management group version 9.5.0.0 until I retire my two G1 servers?

 

Any help will be appreciated.

 

Thanks,

 

Bob

hwelvaar
Occasional Advisor

Re: Upgrade to v10 - problem to detect v9.5 nodeI

From what I've experienced myself, and read in the other threads, yes your mgmt group will stay at version 9.5 until you retire the G1 boxes, or "move" the G1 boxes into a seperate mgmt group so you will have one v9.5 mgmt group with G1 boxes and one v10 mgmt group with G2 boxes.