Showing results for 
Search instead for 
Did you mean: 

Drive failure, can't get into arc menu

April Beachy
Occasional Visitor

Drive failure, can't get into arc menu

We have a Digital Alphaserver  2100  4/233.  It is running Open Vms version 6.2 with SRM console v 4.4-3.


The controller is a Mylex DAC960 and there are 6 drives in a RAID 5 for this particular logical drive.


I have a graphics monitor connected and tried this.  I have tried hooking up a “terminal” on COM1; a computer running SmartTerm connected to the server via the serial port because some comments I saw online indicated that ECU would only work with a serial terminal, not a graphics terminal.


I have the EISA config disk in the floppy, nothing in the CD.  At the P00>>> prompt I have tried ARC, ECU, RUNECU and same results for all.  The server will read the CD drive multiple times, and give the following:


loading ARC firmware

starting console on CPU 0

breakpoint at PC 127190 desired, XDELTA not loaded

Testing Memory bank 0

Testing Memory bank 1

Testing Memory bank 2

Testing Memory bank 3

Configuring Memory Modules

probing hose 0, PCI

bus 0, slot 0 -- ewa -- DECchip 21040-AA

bus 0, slot 1 -- pka -- NCR 53C810

bus 0, slot 6 -- dra -- Mylex DAC960

bus 0, slot 7 -- pkb -- NCR 53C810

probing hose 1, EISA

ECU error, slot 0, found DEC2A01, expected nothing


EISA Configuration Error

Run the EISA Configuration Utility


Memory Testing and Configuration Status

Module   Size    Base Addr   Intlv Mode  Intlv Unit  Status

------   -----   ---------   ----------  ----------  ------

  0      128MB   00000000      1-Way         0       Passed

Then read the CD drive again

Total Bad Pages 0

Testing the System

Testing the Disks (read only)

Testing the Network

AlphaServer 2100 Console V4.4-3, built on Feb  9 1996 at 16:30:17



I need to get into the controller utility to rebuild a hard drive in the RAID to replace the failed drive.  I have poured through the User Guide for this server and it indicates that I can get to the utility by either running the Arc and using the menu or running ECU. Is there some system setting that will point the server to the CD drive instead of the floppy drive for ECU?


Any help you can give is appreciated! 

Bob Blunt
Respected Contributor

Re: Drive failure, can't get into arc menu

April, if you already have a working RAID controller in the system then you should probably skip using ECU totally.  What you probably want is RCU.  Here's a pointer to some info:




ECU is a tool used to setup and configure the various devices that can live in the EISA bus slots on several systems in the Alpha family.  RCU is the RAID Configuration Utility.  I think  if you scrounge around on the pages in the pointer above there should be some pages that also refer to booting RCU from the CD instead of the floppy drive.  IF your 2100 has a graphics interface you should be able to use RCU from it.  The main reasons for providing the directions for non-graphics were for fixing things over dial-up/remote and for systems that didn't have graphics interfaces and attached keyboards, video and mouse.  It shouldn't mean that you HAVE to use serial only.


But seriously the ECU won't have the tools you need to repair disks connected to the RAID controller at all.  RCU is the way you need to go and you should either have a floppy (and the pointer I provided should have directions on making one) or I've seen some directions for booting RCU from the firmware CD.  The actual name of the executable you should be running should probably be RA200RCU for RAID disk repair and/or reconfiguration.



Andy Bustamante
Honored Contributor

Re: Drive failure, can't get into arc menu

As Bob points out you want the RCU utility.  This was also distributed on Alphaserver firmware updates for a time and can be run directly from the CD.  You really really want to run this from the graphics terminal.  It will run from a serial terminal, but the display refresh when building/repairing logical units is painfully slow.  These controllers weren't very graceful and often required manual prompting to rebuild failed units.  If you have support on the system, use field service.  


Obligatory paragraph about dated operating system is included here.  Depending on your business requirements, migration to a virtual Alphaserver will provide better performance and reliability for less than  your service budget.


If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
April Beachy
Occasional Visitor

Re: Drive failure, can't get into arc menu

We do not have support.  This server is not a production server and has not been on support or an upgrade cycle for years.  We are only using it because when we moved off this server some of the data was not correctly migrated by our vendor .  "They are working on this".


Anyhow, the LARGEST issue by far is that I cannot get into the ARC menu.  I have followed the instructions to the letter to get into the ARC menu and it goes back to the P00>>> prompt.  I have ad libbed the instructions and still cannot get into the ARC menu.  Like I said in my first post it will read the CD a few times and display those details.



B Claremont
Frequent Advisor

Re: Drive failure, can't get into arc menu

Can you boot anything using the CD?  Can you boot a VMS installation CD?  If so, you could at least check the status of the data on the drives.

Bob Blunt
Respected Contributor

Re: Drive failure, can't get into arc menu

April, does the 2100 boot AT ALL?  The suggestion to boot from an O/S distro CD is really a good one and it doesn't HAVE to be V6.2, it could be V8.4 or almost anything in between.  We're just trying to get the system to prove itself at a "low level" to see if we're all breaking our heads on the sidewalk or if there's some hope that the box still lives.  It would also be entertaining to know if there has been anything happen to that 2100 since it last ran your application because that family of systems can be a little finicky if something inside is missing or fried.


The simple view of the comments you're mentioning sounds like there might, as mentioned before, be a small chance that your "console" setting isn't matching the interface you're using.  You can provoke the serial port to produce a P000> prompt even when the console is set to "graphics" and vice versa.  Use the interface that SHOWS the POST after you've power-cycled the system.  If you aren't seeing the self-test on either the graphics head or serial port?  That would be most curious and I'd look for multiple graphics cards or some other serial port or interface that might be misleading you.  Possibly check the "standard I/O module" to see if something there isn't connected correctly.  When you find the output of power-on self-test use that interface and type the following:


P00> SHOW * | MORE


And look through that for the setting for the console (either serial or graphics).

If necessary I can spin up an Alpha and refresh myself on the whole ARC and RCU process with both serial and graphics.


Just curious...  Is your 2100 connected to a KVM switch for the video, keyboard and moose?



Valued Contributor

Re: Drive failure, can't get into arc menu

Whenever using a VGA screen (and busmouse+ KB) on a video card in Alpha you use : >> set console graphics (Using a VT220 alike, you use >> set console serial)


For EISA configuration problems, you should do >> runecu  (there must be a specific ECU floppy for VMS Alpha 2200 inserted). You could then clear then the Add board message.


For the Mylex problem you should create a floppy with ra200rcu.exe on it. Insert the floppy and do >> arc

The system must run the ArcBIOS(Windows Shell GUI) instead of the SRM BIOS (>>). Thishas nothing to do with the CD-drive, it's just BIOS.


Then choose Utilities/Run MaintenaceProgram/a:ra200rcu.  When ArcBIOS is not appearing in graphics, then maybe ArcBIOS is never installed (doubt that is the case) , do >> show version When no ArcBIOS then maybe by updating the firmware (Firmware CD V5.6 contains Alpha2200 at last, newer version doesn't support 2200) and then >> b dka500: (the CD drive), then with the UPD prompt, then UPD> update all


There is also a possibility to rebuild the Mylex logical drive on-line, with: $ swxcr rebuild dra x y

(where x =channel 0,1 or 2   and   y=device (0,1,...6). That software must be installed on VMS of course.

In order to $ run swxcr (the GUI version), DECMotif must be installed on your system.