IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

A5800, SNMPv3 and IMC - Device keeps showing up as "Desktop" in AutoDiscovery

SOLVED
Go to solution
tseeney
Occasional Advisor

A5800, SNMPv3 and IMC - Device keeps showing up as "Desktop" in AutoDiscovery

I am attempting to configure an A-Series 5800 switch (with the latest firmware installed) with SNMPv3 for AutoDiscovery on IMC.  After each AutoDiscovery, it lumps the device into the "Desktop" group, reporting it found the device through "ICMP", not SNMP.  Logs of the AutoDiscovery report devices found on ICMP, and SNMP devices found keep coming back as "0".

 

I've done this so many times, I blew the switch config away and started from a bares bones .cfg

 

In Sys view I have done the following:

 

undo snmp-agent mib-view ViewDefault

snmp-agent  mib-view included TEST interfaces

snmp-agent group v3 MANAGEV3GROUP read-view TEST write-view TEST

snmp-agent usm-user v3 MANAGEV3USER MANAGEV3GROUP authentication-mode md5 authkey privacy-mode des56 prikey

snmp-agent trap enable

snmp-agent target-host trap address udp-domain x.x.x.x params securityname MANAGEV3USER v3 privacy

 

I did not set any "community" settings as I believe that is for SNMP v1 and v2?

 

I then setup an SNMP template on IMC for V3 - Priv - Des, Auth - MD5 ....correct user name and passwords from the setup above.

 

Basically, I've followed the instructions on the H3C site, but I'm still getting stumped.

 

Can anyone suggest trying something or identify what I'm missing or doing wrong?

 

When I configure the switch with v2c it works fine and is discovered in IMC.

 

Thanks

4 REPLIES
LindsayHill
Honored Contributor

Re: A5800, SNMPv3 and IMC - Device keeps showing up as "Desktop" in AutoDiscovery

My initial response to this would be to check that my SNMPv3 config was working properly, by using snmpwalk or snmpget from the IMC server, to check that I can get a response with SNMPv3. 

 

This takes IMC out of the picture, and uses small utilities (snmpget/snmpwalk) that should work. Make sure those work, then you know if the problem is with IMC, or somewhere else.

Janick
Visitor

Re: A5800, SNMPv3 and IMC - Device keeps showing up as "Desktop" in AutoDiscovery

I have the same problem. My setup:

 

switch: H3C S5800 (predecessor of HP A5800)

firmware: R1211P09 (also tried R1211P08)

iMC: PLAT 5.2 (E0401P05)

 

I also configured SNMPv3 and snmpwalk from the iMC server works just fine. We've added a lot of these switches with an older version of iMC without any issues. It always detected the right 'device model' and 'device category'.

 

Any suggestions?

 

Thanks!

LindsayHill
Honored Contributor
Solution

Re: A5800, SNMPv3 and IMC - Device keeps showing up as "Desktop" in AutoDiscovery

If it's showing as Desktop, then it means that SNMP is not working properly between IMC and the switch.

Double-check your SNMP settings in IMC, and look at what SNMP logs you can check on the switch, or maybe SNMP debugs.
Janick
Visitor

Re: A5800, SNMPv3 and IMC - Device keeps showing up as "Desktop" in AutoDiscovery

Thanks for your help. Now it all works as expected!

 

At first, I enabled all snmp debugging on the switch. But there wasn't any traffic from IMC... After a reboot of the server, I was finally able to see some debug logs:

 

Apr 26 15:38:36:964 2000 H3C SNMP/7/HEADER:
   incoming SNMPv3 packet
   security model: v3
   security level: noAuthNoPriv
   user name:
   snmpEngineID:
   snmpEngineBoots: 0
   snmpEngineTime: 0

The authPriv information and the username, specified in the SNMP-Template were not transmitted properly.

So I saved the template again (without changing anything) and now it works!

 

Don't know why this happened... might be some problems with the latest IMC update?

 

thx