IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot update WSM 7.2 (E0502) to (E0502P05)

 
Richard Penhale
Occasional Advisor

Cannot update WSM 7.2 (E0502) to (E0502P05)

Hi All,

I am trying to update our WSM to version E0502P05 howerver it fails saying we lack the depancies despite running iMC platform 7.2 E0403P06 and the depandancies requiring E403P03 or newer.

Any pointers to where I am going wrong please?

Kind regards,

Richard

8 REPLIES
Ian Vaughan
Honored Contributor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

Hello,

Which version of WSM are you running now, that you are upgrading from? 

Have you managed to track down the deploy / upgrade logfile to see if there is any additional info? 

This support article might help collect those pesky log files,

Let us know how you get on. 

Thanks

Ian

Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me
NeilR
Respected Contributor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

I beleive you are getting that because the IMC plaform itself needs to be upgraded past E403P03. 

E0403P04 and P06 were released and posted for the IMC Platform. You could update to either one and then update WSM.

I'm running Plat at p06 and WSM at p05

Ian Vaughan
Honored Contributor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

Hi Neil,

I've managed to upgrade my WSM to the point of breaking so I've pretty much replicated what Richard did. 

I'm going to patch up the platform to p06 and revisit the WSM as well as my previously broken APM. 

I'll let you know how I get on.

Thanks

Ian

Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me
Richard Penhale
Occasional Advisor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

We are running iMC basic 7.2 E0403P06, which according to the WSM readme is a compatible version to support the WSM update.

Richard Penhale
Occasional Advisor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

We are already running 7.2 E0403P06 iMC basic so this is not the problem unfortunately.

Richard Penhale
Occasional Advisor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

Hi Ian,

I have downloaded the log files, any idea where I need to look in the zip file to find some relevant troubleshooting info. The install didn't proceed as the depandancies were not met (despite running the most recent version of iMC), so will there be anything relevant logged though?

Many Thanks,

Richard

Ian Vaughan
Honored Contributor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

Hi Richard,

I found one of the logfiles at - /opt/iMC/deploy/log/deploylog.txt - but then again I am one of the few who actually has iMC installed on Linux so your path might start differently and have the wrong slashes in it :-) 

My (old) deploylog says that WSM didn't install as I seemed to have an existing WSM slave install?? That's very odd as AFAIK I've never deployed a WSM slave. I will investigate. 

Once I get Xming working again I'll be able to open a GUI to run the deployment tool #yesitwouldhavebeeneasieronwindows

and I'll update the Platform before trying again with WSM.

Cheers

Ian

Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me
Ian Vaughan
Honored Contributor

Re: Cannot update WSM 7.2 (E0502) to (E0502P05)

Hello,

From the deploylog.txt

WSM now installs after Platform update to E403P06 - yay!

--------------------------------------------------

Timestamp: 2016-08-25 23:31:36
Component ID: iMC-WLAN
Name: Wireless Service Manager
Version: iMC WSM 7.2 (E0502)
InnerVersion: V700R002B05D002
Address: 127.0.0.1
Operation: Deploy completed
Result: success
--------------------------------------------------

And:

--------------------------------------------------

Timestamp: 2016-08-26 00:13:26
Component ID: iMC-WLAN
Name: Wireless Service Manager
Version: iMC WSM 7.2 (E0502P05)
InnerVersion: V700R002B05D002SP07
Address: 127.0.0.1
Operation: Update completed
Result: success
--------------------------------------------------

Patch upto P05 looks OK. Topology etc seems fine.

## Rereading the original question - was there a mention of iMC Basic + WSM rather than iMC Standard?

Is it the right build of WSM (are they different between the version that goes with Basic and the one that goes with Standard?) that is being deployed.

Hope that helps please share your thoughts & experiences - there seems to be a bit of a glut of iMC & WSM questions over the last few days.

Thanks

Ian

Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me