Showing results for 
Search instead for 
Do you mean 

Configuration Deployment Fails

Regular Visitor

Configuration Deployment Fails

I'm attempting to deploy a configuration segment to one of our 2626B switches, but I'm encountering errors


The task fails on the "Deploy running configuration file to device." step with the message "The device does not support the features."


The configuration segment is simply setting a SNMP trap reciever as follows:

snmp-server host not-info "snmpcommunity"


Can anyone point me in the right direction as to what my issue might be? Thanks!

Honored Contributor

Re: Configuration Deployment Fails

When you defined the configuration segment, did you set the applicable devices correctly? 


If it doesn't think that the config can be applied to that sort of device, it will stop you deploying it.

Regular Visitor

Re: Configuration Deployment Fails

I had not set the applicable devices, however after setting them and ensuring the 2626B is in the list there still is no change. I've also created a new deployment task after making the changes rather than just re-running the existing one with no effect.

Frequent Advisor

Re: Configuration Deployment Fails

Looking at the device page, is the iMC recognizing it as a 2626B switch?

Aaron Paxson
@Neelixx |
Honored Contributor

Re: Configuration Deployment Fails

Only other things I can think of are:
* Credentials set right for this system? (SNMP, Telnet/SSH)?
* File transfer mode set right?
* Have you tried doing it as CLI script, rather than segment?
* May need to check the adapter for that specific switch, make sure it's fully supported by IMC, and it has a deploy script.
Regular Visitor

Re: Configuration Deployment Fails

Thanks for the ideas everyone.


The swtich is indeed being detected properly as a 2626B in iMC. I've tried it as a CLI script and it worked, so I assume that would also indicate that the credentials are valid for the swtich.

I could definitely see file transfer mode as being a possibility. Right now iMC is set to TFTP as I couldn't seem to run things such as automated config backups in FTP mode. Does pushing configuration like this require something other than TFTP?

Honored Contributor

Re: Configuration Deployment Fails

I haven't fully got my head around it, but there's a couple of different things going on with segments vs CLI scripts. If it's a segment, IMC will try a couple of different things:

* Use snmp-set, to tell the device to retrieve a config from a TFTP server (running on the IMC server). This requires SNMP read-write, and the device must be able to connect to the IMC server using TFTP. If this fails, it tries the next option:

* Login via CLI, and tell the device to retrieve the config using tftp. It's the equivalent to telnetting to the device, going to enable mode, and entering "copy tftp://<IMC_IP>/file running-config". If the device is managed via SSH, then it should not run this step (since it's insecure), but should go the the next option:

* If the device is managed via SSH, AND you have set the file transfer mode to SCP, it should use SCP to copy the file out to the device. Note that if you're using this method, you must have SCP enabled on the device. "ip ssh filetransfer" on Procurve I think. If it's a Cisco device, you need to enable SCP, and ensure that you have AAA set right to allow direct SCP of a segment to the running or startup config.


CLI scripts are obviously a bit different, since it just logs in (using Telnet or SSH, depending on device), and runs the specified commands.


Regards the FTP backup issue, this does work. Be aware of the direction - IMC will login to the device, and tell it to send/receive files to/from the FTP server running on IMC. The thing to watch out for is that you need to set up your own FTP server, make sure it has the right user and permissions configured, and the right home directory. Then configure IMC with those credentials.