IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

DMA Slave cannot connect to Master after 7.3 upgrade

SOLVED
Go to solution
RPapaux
Frequent Advisor

DMA Slave cannot connect to Master after 7.3 upgrade

Hello,

I have started to upgrade my IMC environment (1 Master and 1 Slave) on 7.3

As recommend I have downloaded and installed all modules with 7.3 compatible versions.

The upgrade on the Master (IMC-Plat and NTA) went well. However on the Salve side when I start the DMA it automatically download the COMMON services from the master and silently shutdown without any Warning or Error.

The dma logfile (which is attached) says "Can not find the JRE included with the installation disk" !!! and suggest to perform the upgrade manually using:

[C:\Program Files\iMC\deploy\jdk\bin\javaw.exe, -Xmx256m, -cp, C:\Program Files\iMC\deploy\components\common\deploy\deploy.jar, com.h3c.imc.deploy.CommonComponentUpdateLauncher, autoStart]

When I do it I'm getting a PopUp window saying that it could not fing the main class (see attached file; sorry for the rendering quality:|).

I'm not familiar at all with JAVA, but it looks like a PATH is missing or a VARIABLE not defined somewhere.

Has someone alread gone through this, or suggest any clue to troubleshoot it further.

Thanks

Ray

 

 

2 REPLIES
Josef_B
Occasional Visitor

Re: DMA Slave cannot connect to Master after 7.3 upgrade

Hello Ray -  i have had the same problem - this was my solution:

On the slave - have a look into :  windows/IMC-Reserved/log -> there should be a file like this: update_xxxxxxxxxxxx.txt which is the logfile of your latest installation. xxxxxxxx means Date and time .  Open the file -> do you see such like this:

2017-03-01 10:14:27 [ERROR] [main] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::checkEnv(140)] Can not find file: F:\Program Files\iMC\deploy\components\common\deploy\jdk_windows64.zip

If this is your message - then do the following:

Go to:  $imc-install -drive/Programm Files/iMC/deploy/components/common/deploy 

In this directory - search for a zip file  - jdk_windows.zip -> rename this file into jdk_windows64.zip

Now your deploymemt on the slave should work well. 

HTH

 

 

 

 

RPapaux
Frequent Advisor
Solution

Re: DMA Slave cannot connect to Master after 7.3 upgrade

Thank you for this detailled information. IMC has so many log files that I was not aware the Windows\IMC-Reserved\log.

Nevertheless I have scanned all the files in there and could not find the error you described.

As I was on time pressure I was ready to sacrify the slave server and reconfigure it (it is a test system after all).

So after lot of sweat and some increase in my blood pressure I have run the installslave script from the IMC installation directory.

Fortunatelly the script has detected there was already an installation and has started the upgrade process  (miracles sometimes still happen) and the upgrade finally completed.

Caution: IMC has tried to kill me a second time when it asked me for the "sa" password that I have never provided in my first installation !!!

Thanks to a very usefull blog I have tried "iMC-Install2008" and it worked...

So the problem is solved, but I never knew the root cause.