IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

Device software import fails on HP 2510, but works on HP 2530

 
siffo
Occasional Visitor

Device software import fails on HP 2510, but works on HP 2530

Hi,

 

I've been testing HP IMC Enterprise for a while now. Now i'm struggling with device software import, for me it seems quite strage that it works on HP 2530 -series (YA15.xxx) but not with HP 2510 -series (Q_11_67). The result from 2510 is always the same - zero size file in software library. If I look from IMC logs, they state that the import was finished "OK". IMC transfer method is SCP (also tried SFTP).

 

Does someone have ideas what could cause this?

 

P.S. configuration backup/restore works fine with both device series.



5 REPLIES
LindsayHill
Honored Contributor

Re: Device software import fails on HP 2510, but works on HP 2530

If you try and manually SCP/SFTP the software image off the switch, does it work?

siffo
Occasional Visitor

Re: Device software import fails on HP 2510, but works on HP 2530

Yes, manually I'm able to retrieve the image off the 2510 switch.

 

 

LindsayHill
Honored Contributor

Re: Device software import fails on HP 2510, but works on HP 2530

Do you have the same login type & file transfer type for the 2510 and the 2530?

 

Try running a software import, and looking at the logfiles in <IMC>/server/conf/log/, and see what's going on. They can be a bit tricky to read, but sometimes they'll give you more detail about why the job is failing.

LindsayHill
Honored Contributor

Re: Device software import fails on HP 2510, but works on HP 2530

Also meant to ask - which version are you using? There's a couple of fixes around software image management via SCP for Procurve devices in the 7.x patches.
siffo
Occasional Visitor

Re: Device software import fails on HP 2510, but works on HP 2530

Thanks for the help so far.

From log file I'm able to find these relevanta lines:

2014-07-25 10:05:23.150 [WARNING (18)] [THREAD(11372)] [CExecuterValue::initImageEntry()] Failed to get backup image info by scripttool.
2014-07-25 10:05:23.153 [WARNING (5006)] [THREAD(11372)] [CSoftwareLibMgr::getDevTransferProtocol] not found transfer protocol:6
2014-07-25 10:05:23.153 [INFO (0)] [THREAD(11372)] [CExecuteTask::do_task__()] Begin to upgrade/backup device software by scripttool ....
2014-07-25 10:05:23.153 [INFO (0)] [THREAD(11372)] [CExecuter::exec()] step: 1002
2014-07-25 10:05:24.155 [INFO (0)] [THREAD(11372)] dev id: 6, ip: 10.10.10.10. CPolicyProcurveBackupToNMS::exec() begin .......
2014-07-25 10:05:24.155 [INFO (0)] [THREAD(11372)] dev id: 6, ip: 10.10.10.10. Transfer file to NMS begin .......
2014-07-25 10:05:25.214 [ERROR (-100)] [THREAD(11372)] [CProcurveConfigMgmt::CProcurveConfigMgmt()] Failed to call qvdm::getLocalConnectIP(),dev_ip = 10.10.10.10
2014-07-25 10:05:25.216 [INFO (0)] [THREAD(11372)] [CProcurveConfigMgmt::backupImage()] Begin.
2014-07-25 10:05:25.216 [INFO (0)] [THREAD(11372)] [CProcurveConfigMgmt::execCmdList()] Begin.
2014-07-25 10:06:28.182 [ERROR (2)] [THREAD(11372)] [CSSHService::receive()] Failed to call getresponse()
2014-07-25 10:06:28.255 [INFO (0)] [THREAD(11372)] [CProcurveConfigMgmt::execCmdList()] End.
2014-07-25 10:06:29.926 [INFO (0)] [THREAD(11372)] [CProcurveConfigMgmt::getFileFromDevBySftp()] Open sftp connect to device.
2014-07-25 10:06:29.926 [INFO (0)] [THREAD(11372)] [CProcurveConfigMgmt::getFileFromDevBySftp()] Get file started.
2014-07-25 10:06:30.076 [INFO (0)] [THREAD(11372)] [CSFTPService] close
2014-07-25 10:06:30.076 [INFO (0)] [THREAD(11372)] [CProcurveConfigMgmt::getFileFromDevBySftp()] Get file finished.
2014-07-25 10:06:30.100 [INFO (6)] [THREAD(11372)] [CSnmpOper::iCommitOper] send snmp set packge fail.->[10.10.10.10]
2014-07-25 10:06:30.100 [ERROR (6)] [THREAD(11372)] [CProcurveConfigMgmt::setDevMibNodeValue()] Failed to call iCommitOper.
2014-07-25 10:07:00.102 [INFO (5501)] [THREAD(11372)] [CProcurveConfigMgmt::backupImage()] End.
2014-07-25 10:07:00.102 [INFO (0)] [THREAD(11372)] dev id: 6, ip: 10.10.10.10. Transfer file to NMS end .......
2014-07-25 10:07:00.147 [INFO (0)] [THREAD(11372)] dev id: 6, ip: 10.10.10.10. addSoftwareToDB() success,image: Q.11.67
2014-07-25 10:07:00.147 [INFO (0)] [THREAD(11372)] dev id: 6, ip: 10.10.10.10. CPolicyProcurveBackupToNMS::exec() end .......
2014-07-25 10:07:00.147 [INFO (0)] [THREAD(11372)] [CExecuter::exec()] StepID : 1002 success !
2014-07-25 10:07:00.147 [INFO (0)] [THREAD(11372)] [CExecuter::exec()] setExtendResult: 6;Q.11.67;0
2014-07-25 10:07:00.147 [INFO (0)] [THREAD(11372)] [CExecuter::exec()] notify: { -- SEQUENCE --
iSessionID '28'H --
,
iJobID '33'H --
,
iDevID '06'H --
,
iExtendStatus '04'H --
,
iResultCode '01'H --
,
iExtendResultCode '157d'H --
,
strExtendResult ''H -- "" --,
bFinished FALSE,
iStepID '03ea'H --
,
iFileType '02'H --
,
bStepFinished TRUE
}
2014-07-25 10:07:00.147 [INFO (0)] [THREAD(11372)] [CExecuteTask::do_task__()] End to upgrade/backup device software by scripttool.
2014-07-25 10:07:00.147 [INFO (0)] [THREAD(11372)] [CExecuteTask::do_task__()] End to do task.


The transfer methdon for both switches is SCP. IMC version was just updated a few days ago and it is PLAT 7.0 (E0202P03).