IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

IMC 7.0 installation problem - Server2008

castle87
Occasional Collector

IMC 7.0 installation problem - Server2008

Hello,

 

I am trying to set up IMC 7.0 on a Server 2008 R2(x64) system with MySQL 5.5, but having some problems when the installation tries to validate the database setup.

 

The following error occurs during the check-up:

 

Checking Database Parameter Configuration...
Not Passed
The following database parameters do not meet the installation requirements. Please modify the configuration according to the iMC MySQL database installation and configuration guide and try again: max_connections

 

 

I have followed the installation guide for MySQL 5.5 and have re-installed it 2 times. The max_connections setting in the my.ini is max_connections=200. Is this a known problem and/or is there a solutions for this?

 

Thanks in advance.

 

 

Edit: max_connections typo

5 REPLIES
LindsayHill
Honored Contributor

Re: IMC 7.0 installation problem - Server2008

You seem to have a typo there - the parameter is max_connections = 200, but you've put max_connection = 200.

 

Is that a typo in your config file, or just in the post here?

castle87
Occasional Collector

Re: IMC 7.0 installation problem - Server2008

Thanks for your quick respond.

 

Unfortunatly it was a typo in my post and not in my script.

Dennis Handly
Acclaimed Contributor

Re: IMC 7.0 installation problem - Server 2008

>Unfortunately it was a typo in my post and not in my script.

 

You can correct it by using Post Options > Edit Reply

Drew_38
Frequent Advisor

Re: IMC 7.0 installation problem - Server2008

Did anyone ever discover a solution to this issue? I'm in the middle of an IMC installation on Windows and having exactly the same problem with the install script checking the max_connections setting.

Borislav Ivanchev
Occasional Advisor

Re: IMC 7.0 installation problem - Server2008

Where did you change this parameter?

 

It should be as the manual says in _ProgramData_ and not in Program Files (x86) \. .\my.ini


"The default configuration file my.ini in the data path for the MySQL server determines the functions
and performance of the MySQL server. The default data path for the my.ini file is
C:\ProgramData\MySQL\MySQL Server 5.5."

 

You can verify if the parameter was actually changed within MySQL:


C:\>mysql -u root -p
Enter password: ********
Welcome to the MySQL monitor. Commands end with ; or \g.

[...snip...]

mysql> select @@max_connections;
+-------------------+
| @@max_connections |
+-------------------+
| 400 | <<<
+-------------------+
1 row in set (0.00 sec)

mysql>

 

Please be careful and don't copy/paste the parameter. Find it in my.ini and change it.