Showing results for 
Search instead for 
Did you mean: 

IMC 7.2 to 7.3 upgrade

Regular Advisor

IMC 7.2 to 7.3 upgrade

Hi All

Upgrading from iMC PLAT 7.2 (E0403) to 7.3 (E0506) and getting the below, anyone has come across this error? Worth mentioning that the file mentioned in the log doesn't exist (C:\Program Files\iMC\client\web\apps\rpt\WEB-INF\lib\imcweb_plat.jar)

log is the part of dmslog.txt file C:\Program Files\iMC\client\web\apps\rpt\WEB-INF\lib\imcweb_plat.jar (Access is denied)
	at Method)
	at com.h3c.imc.deploy.FileUtil.copy(
	at com.h3c.imc.deploy.tasks.FileCopyTask.executeTask(
	at com.h3c.imc.deploy.tasks.SimpleTask$a.a(
	at com.h3c.imc.deploy.tasks.SimpleTask$a.doInBackground(
	at java.util.concurrent.FutureTask$Sync.innerRun(
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
	at java.util.concurrent.ThreadPoolExecutor$


in deployment agent getting the below 


Honored Contributor

Re: IMC 7.2 to 7.3 upgrade

It looks like someone have been already hitted by a very similar issue and solved, see here.

I'm not an HPE Employee
Kudos and Accepted Solution banner
Regular Advisor

Re: IMC 7.2 to 7.3 upgrade

Also in deploylog file just found this :

Timestamp: 2019-05-20 16:26:28
Component ID: iMC-REPORT
Name: iMC Platform - Report Management
Version: iMC PLAT 7.3 (E0506)
InnerVersion: V700R001B06D018
Operation: Update completed
Result: failed
Fail reason: Performing deployment or upgrade on the master server failed. For details, see the log on the master server.
Regular Advisor

Re: IMC 7.2 to 7.3 upgrade


Esteemed Contributor

Re: IMC 7.2 to 7.3 upgrade

I did not have this problem, so can't tell you much other than I upgraded incrementally, as they were released.

So I went from 7. 2 E0403P10 to 7.3 E504 and then on from there as patches were released.

Sometimes there are changes to the DB schema that are assumed to be in place from prior updates in order for the current one to succeed. 

The release notes also have a section on which predecessors will work for the current release.

So don't know if you tried going to the immediate next major release E504. and then forward from there.


Regular Advisor

Re: IMC 7.2 to 7.3 upgrade

I've tried from 7.2(403) to 7.2(403P04) getting the same error, the only difference is that I am able to start IMC but half of components are not deployed

Esteemed Contributor

Re: IMC 7.2 to 7.3 upgrade

The file imcweb_plat.jar mentioned in the log does exist in my current configuration. Looks like from the post Parnassus referenced putting it back might work,

Might be able to find it in the  install zip files? Or worst case install a fresh copy and find the file and copy it.

Regular Advisor

Re: IMC 7.2 to 7.3 upgrade

I've tried that, I copied one from previous version - desperate for solutions.

I also tried looking for in in the zip file but no luck


Re: IMC 7.2 to 7.3 upgrade


A few questions:

- Did you check for the SSL Cipher issue mentioned in the initial reply? IMC 7.3 E0605 onwards includes a new MSKBsC.exe that can automatically remove the affected ciphers. Just run it on the IMC and DB server on CMD and follow the output.

- Do you use a local or a remote DB?

- Have you restored the DB using any other tools than IMC's dbman (Deployment Monitoring Agent 'Backup' and 'Restore' buttons)?

There were some issues in the past where the Report Management failed because of non-dbman restores of the DB (eg. via SSMS), causing the 'report' user's mappings/schemas to be lost or incorrect.

I have an embedded DB lab system that was upgraded successfully over the years from 7.1 E0302 -> 7.2 E0403 -> 7.3 E0506 and onwards without any such issues, so I'd suspect that it is a DB- or deployment-related issue.

Best regards,

Working @ HPE
Accept or Kudo
Regular Advisor

Re: IMC 7.2 to 7.3 upgrade

Hi Justin 

Just an update, not a good one. I'm not able to update to any patch within 7.2 from 7.2 either, same error

1. yes I have ran MSKBsC.exe, can I based on the below assume there's no issues detected?

IMC cert check.PNG

2. Local data base - IMC and DB on the same server 

3. No, DB has been restored using IMC deployment tool 

Is there a place where more specific logs are placed?  I'm really stuck with this