IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

IMC MySQL max_connection error

AgentZoy
Occasional Contributor

IMC MySQL max_connection error

HI

I'm trying to install HP IMC+MySQL ver 5.7 and get error Checking Database Parameter Configuration... Not Passed The following database parameters do not meet the installation requirements. Please modify the configuration according to the iMC MySQL database installation and configuration guide and try again: max_connections

My mysql config file

# For advice on how to change settings please see
# http://dev.mysql.com/doc/refman/5.7/en/server-configuration-defaults.html
# *** DO NOT EDIT THIS FILE. It's a template which will be copied to the
# *** default location during install, and will be replaced if you
# *** upgrade to a newer version of MySQL.

[mysqld]

# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
innodb_buffer_pool_size = 512M

# Remove leading # to turn on a very important data integrity option: logging
# changes to the binary log between backups.
# log_bin

# These are commonly set, remove the # and set as required.
# basedir = .....
# datadir = .....
# port = .....
# server_id = .....
lower_case_table_names=1
character-set-server=latin1
innodb_buffer_pool_size=512M
innodb_additional_mem_pool_size=16M
max_allowed_packet=200M
max_connections=500
# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M 

sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES 

Whats wrong?

 

5 REPLIES
LindsayHill
Honored Contributor

Re: IMC MySQL max_connection error

I set max_connections to 400 with MySQL 5.6, and that works.

IMC 7.2 does not officially support 5.7 (only 5.5 & 5.6). That may be part of your problem (i.e. it's failing checks because of something else, but it gets misreported as a max_connections issue).

AgentZoy
Occasional Contributor

Re: IMC MySQL max_connection error

I downgraded my sql to ver 5.6 and got the same error Whats wrong?

LindsayHill
Honored Contributor

Re: IMC MySQL max_connection error

What happens if you use 400, not 500?

AgentZoy
Occasional Contributor

Re: IMC MySQL max_connection error

the same error

LindsayHill
Honored Contributor

Re: IMC MySQL max_connection error

This is the contents of my my.cnf file. Works with both IMC 7.1 & 7.2, using MySQL 5.6 on RHEL 6.x.

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
port=3306
max_connections=400
character-set-server=latin1
default-storage-engine = INNODB
lower_case_table_names=1
innodb_buffer_pool_size=512M
innodb_additional_mem_pool_size=16M
max_allowed_packet = 200M
[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid