IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

IMC NTA process fails to start

baser
Occasional Contributor

IMC NTA process fails to start

Hello,

 

I installed and deployed IMC 5.1 on a Windows Server 2008 R2 using an embedded SQL data base. I also deployed NTA module among others.

 

When I start IMC, all processes show a status of "started" but there is one process called processor.exe (which belongs to NTA module), that after 5 minutes showing a status of "starting", it shows "unknown error occured". I try to start the process manually but after a few minutes the status shows "stopped".  

 

Does anyone know how to start processor.exe process or troubleshoot the issue?

 

Due to this processs not successfully starting, when I try to deploy my NTA server configuration, deployment fails and NTA doesn't work.

 

Thanks and regards

 

4 REPLIES
LindsayHill
Honored Contributor

Re: IMC NTA process fails to start

I'm not sure why it's doing that, but I'd probably start by digging into the logs.

 

Look at <imc_dir>\unba\log\processor.<date>.txt as a starting point. Might get lucky and find something meaningful in there.

baser
Occasional Contributor

Re: IMC NTA process fails to start

Thanks for your reply northlandboy.
 
I think I had an issue with the processor.exe process caused by installing the NTA 5.1 module after installing the IMC PLAT 5.1 SP1 but I can't be 100% sure.
 
I upgraded to IMC version 5.2 and also upgraded all my modules to version 5.2, and now NTA now works fine (processor.exe successfully starts).
 
Thanks again and regards.
LindsayHill
Honored Contributor

Re: IMC NTA process fails to start

Yes, that can cause a problem if you upgrade the base platform, but not the modules. 

 

I can't remember if SP1 warned you about it or not, but you would have noticed that the 5.2 upgrade will complain if you have other modules that need to be updated at the same time.

 

Good to hear it's working (and that you've already upgraded to 5.2!)

baser
Occasional Contributor

Re: IMC NTA process fails to start

Thanks again northlandboy :)