IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

IMC - Standard V7.1 (303) - SQL Remote DB Fail

larrymac
Frequent Advisor

IMC - Standard V7.1 (303) - SQL Remote DB Fail

Hi All

 

We are trying to install new IMC Standard V7 on VM with remote SQL 2012.

 

The Native Client is installed on the VM.  In Control Panel it is part of installed programs.  We have proven connectivity between native client and SQL server. 

 

When running install on IMC it does not seem to recognise that the SQL native Client is already installed and then installs the Embedded SQL Express 2008.

 

I have tried numerous times and it does the same thing always:

 

"Checking database installation....

Database or Database Client in not installed in this computer.  Checking prerequisites for embedded database...

Current system allows the use of embedded database.  Click "Continue" to continue"

 

Has anyone come across this?  I assume that the IMC should recognise the Native Client 2012 is installed and not install the embedded express.

 

Thanks

4 REPLIES
LindsayHill
Honored Contributor

Re: IMC - Standard V7.1 (303) - SQL Remote DB Fail

When you installed the SQL Management Client on the IMC server, did you also select the option for "SQL Client Connectivity SDK" ?

raf2
Frequent Advisor

Re: IMC - Standard V7.1 (303) - SQL Remote DB Fail

You might prepare your DBA (if you're lucky enough to have one) for iMC placing all data and log files in the same location.  The installation gives you no options for placing files like DBA's typically like to do. I had to move the dozen or so log files in both implemenations I've done.

 

Hoping HP will change this.

 

Good luck. BTW You can open a case with HP even if you don't own the product.

 

Ron

Re: IMC - Standard V7.1 (303) - SQL Remote DB Fail

I've taken a look: the Install program looks for the existence of the following, specific registry keys:

  • HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft SQL Server 12
  • HKLM\SOFTWARE\Wow6432Node\Microsoft\Microsoft SQL Server\120\Tools\ClientSetup

 

I've manually created those keys, which causes the installer to prompt for the SQL details, but it then fails on the next step, saying that some components are missing. Specifically, it looks for bcp.exe but looks like it also needs osql.exe and possibly other components.

 

This means that even though iMC supports using earlier releases of SQL and it's intimated that only the Native Client is required, the installer *requires* that some components of SQL Server 2014 are installed through checking for version-specific registry keys. Ironically, it looks like the Native Client might not be needed at all, when I was under the impression initially that’s the only component required.

 

The bits that seem to be needed for iMC installation are osql.exe and bcp.exe. While bcp.exe is available one of the separately-downloadable components, the only way I’ve been able to get osql.exe on a system without simply copying it across was as part of the Management Studio install (aka “Management Tools - Basic”) component of the SQL Server 2014 installation.

 

So, in summary, to install iMC with a remote Microsoft SQL Server it looks like one needs to install SQL Management Studio (aka “Management Tools - Basic” in SQL Setup.) In case you’re licensed for an earlier release than SQL Server 2014, I anticipate that installing Management Studio Express (“free”) would also address the dependency without licensing impact.  I did not have to install any other components to get it to work, but selecting the "Management Tools - Basic" component installs a number of dependent bits as well - including the Native Client.

larrymac
Frequent Advisor

Re: IMC - Standard V7.1 (303) - SQL Remote DB Fail

Hi All,

Just getting back to this today...  We have the SQL client setup correctly.  We added in a path on VM to the SQL db.

But it failed on connectivity test so unable to progress with the install. 

To make some progress we decided to just use the local embedded SQL as the DB will not be that big.  It would have been better to have the DB on the SQL server but after reading lots of manuals, opening a support ticket we still could not get it to work.

Now we thought this wil be simple and straight forward but alas we now have another problem.

We un-installed any reference to SQL and IMC.

Started a fresh install on the VM and it installed the embedded SQL and then installed the IMC platform.

But when it tried to deploy the components it fails.

It directs us to a log file in temp directory which seems to fail on deploying to Slave.  We are not using any Master/Slave scenario so uninstalled again and tried again. After 3 attempts, still it will not deploy any components.  The same error all the time.  "slave deploy failed".  An absolute disater of a day!

We are installing on Win 2012 R2 Standard with 6GB of RAM allocated. 

We are using V7.1 (303) and if succesful will be updating to latest patch.

Has anybody else experiened issue with deploying components?   I have used this verison on 2 other installs over the summer without issue.

Thanks