Showing results for 
Search instead for 
Did you mean: 

IMC failing to backup 3Com 2952's

Go to solution
Occasional Contributor

IMC failing to backup 3Com 2952's


We have a few different switches that we are managing via IMC, but we're having a problem backing up our 3Com 2952's. The error we are getting is "Failed to execute script." with the following details:

<2952-01 (DC15)>display startup
% Unrecognized command found at '^' position.
<2952-01 (DC15)>

This leads me to believe that they are not correctly being put into cmdline-mode so the command is invalid, but I could be well off the mark.

I've tried adding these to a separate adapter, and rewriting the adapter ensuring that this is included but had no joy (although I could confirm that I managed to get  these switches at least trying to use the new adapter). It is entirely possible that I am writing the adapter wrong too so don't rule that out straight away.

IMC is backing up our HP1910 switches fine. Both the 1910's and the 2952's are running Software Version 5.20 Release 1519P03 and similar configs.

Has anyone had a similar problem, and how did you get it working?
Please let me know if there's any more information you need.

Thanks in advance

Honored Contributor

Re: IMC failing to backup 3Com 2952's

Use SCP instead?

Occasional Contributor

Re: IMC failing to backup 3Com 2952's

Got it working:

Regardless of where I put the OID, IMC would revert back to using the H3CCommon scripts. Adjusting the adapter in here to include the extended commandline worked fine.

Just need to refine my scripts now to ensure that it won't cause errors when trying to backup kit other than the 2952's and that should be that. I will update if I discover this has caused any errors.

Thanks for your reply anyway Lindsay