IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

IMC not displaying SNMP traps

C_Anderson
Occasional Contributor

IMC not displaying SNMP traps

Hi - I'm trying to get IMC to show traps send by network devices.

I can see the traps being sent to IMC are arriving with wireshark on the IMC server, but none are showing in the Alarm > Trap Management > Browse Traps page.

I have disabled 'Unknown Trap filter' and 'Trap Filter of Devices not in IMC' and do not have any other filters.

Can anyone point me where to investigate next to try to show SNMP ttaps in IMC?

Thanks.

Current switch config:

snmp-server community "<string1>" operator unrestricted
snmp-server host <IMC IP> community "<string1>" trap-level all
snmp-server enable traps startup-config-change
snmp-server enable traps running-config-change

2 REPLIES
NeilR
Respected Contributor

Re: IMC not displaying SNMP traps

go to the device details page, test the snmp settings under configure/modify snmp settings (if u hadn't already done so).

if test no good, then fix snmp settings.

If test ok then select trap destination tab - it should show the settings you made on your switch.

If not visible, then synchronize and refresh. If nothing is set then try the add trap destination link on the right - this will attempt to add the settings imc thinks are correct for that device.

LindsayHill
Honored Contributor

Re: IMC not displaying SNMP traps

Things to check:

* Windows/Linux system firewall - does that allow inbound UDP/162?

* 'netstat -an' output. Is the system listening on UDP/162? Add the appropriate flag to check the process ID too (netstat -unlp on Linux, I think netstat -anb on Windows)