Showing results for 
Search instead for 
Did you mean: 

Password problem after migration IMC 7.3 E0506P07

Go to solution
Occasional Advisor

Password problem after migration IMC 7.3 E0506P07


I did an IMC migration from a Windows server 2008 in 7.3 E0504P02 to Windows Server 2012 R2 in 7.3 E0504P02 too, restoring the data from the old server.  Everything went well, no error during migration.. I was able to login and display my datas. Then I upgraded it to the E0506, start it everything ok, and then to the E0506P07.

Now i'm facing a problem. I'm able to login with my admin user, with the password from the old IMC but the other users (local or AD) cannot. The LDAP server autentication is ok (I used the test button). When do this I not able to login anymore with the "admin" local user. I have to restart the IMC services to re-login.

I tried to create a new local user, for example "localadmin". But impossible to login with it and after creation, unable to relogin with the "admin" user. I have to restart the IMC services to re-login again.

Has anyone faced this issue ? Any solution or suggestion ?


Respected Contributor

Re: Password problem after migration IMC 7.3 E0506P07

I also upgraded my IMC server to 2012R2 and am not having this issue. But our domain level is still 2008R2. That's possibly one issue.

Here's my LDAP server settings under System>Authentication server if that helps:

Note the test button only tests whether the Admin account can access the LDAP server AFAIK - I don't think it actually confirms any of the rest of the settings.

  • LDAP version: 3
  • Server Type: AD
  • Port: 636 if using LDAP over ssl
  • Base DN - top level of your domain
  • Admin DN - CN for your admin account and PW which your test indicates is good
  • Username Atrribute - I'm using sAMAccountName - should match your login
  • require SSL Checked to match port, and a valid certificate loaded.
Frequent Advisor

Re: Password problem after migration IMC 7.3 E0506P07

because local users are also affected, I do not think it is ldap related, I think it is more related to the imc_config.tbl_plat_operator (or one of its dependencies)

What error do you get, when you try to login? (Operator or password is incorrect, a jserver exception, or  is the Homepage simply not displayed? )

for the buildin admin account you can try to reset the password with:

in Windows cmd

<imc installation path>/client/bin/resetpwd.bat (this will reset the admin password to admin)

after that, do you still have the problem that you need to restart IMC to login as admin again?

How did you perform the IMC migration?

Occasional Advisor

Re: Password problem after migration IMC 7.3 E0506P07

Hello, Thanks for your answers.

  • I ran the resetpwd.bat. Admin with admin as password works. 
  • I ran the LDAP test and save the LDAP config, admin still works.
  • I modified a local user password, now admin login fails and unable to login with the local user I changed the password.

I get no error, the login form just reset itself. The LDAP autentication doesn't work either.

I reset the password of the account in the LDAP settings, without resolution.


For the migration path you asked:

  • On the new server, I installed SQL Express 2014. (The old is in 2008)
  • Then I installed the same IMC products as the old one. Ran the services between each steps. Installation order:
    1. iMC_PLAT_7.3_E0504_Std
    2. iMC_PLAT_7.3_E0504P02
    3. iMC_NTA_7.3_E0502
  • On the old server, I backuped the database.
  • On the new, I restored the database. Ran the services, test the admin login, it was ok.
  • Then I upgraded to the last version with the following order, starting and login between each steps:
    1. iMC_PLAT_7.3_E0506_Std
    2. iMC_PLAT_7.3_E0506P07
    3. iMC_NTA_7.3_E0505
    4. iMC_NTA_7.3_E0505P01
Frequent Advisor

Re: Password problem after migration IMC 7.3 E0506P07

this indeed sounds very strange

could you please:

enable jserver debugging for a short time (System => Sytem Configuration => Log Configuration)

if database is remote start a wireshark trace (to see the tds communication)

reproduce the problem (try an unsuccessfull login, best with a local account) disable the jserver debugging, stop the wireshark trace

collect the $IMC/client/log/imcforeground.log and the wireshark trace

if you want you can contact me directly via mail:

Re: Password problem after migration IMC 7.3 E0506P07


The database is on the same server so a wireshark trace is of no value. Everything worked fine with the exception of the error shown. IMC worked fine but the service error displayed was of concern.

I have since restored from snapshot and upgraded to 7.3 E0506 and it is working fine. I have a test server which upgraded several weeks ago fine but the ten IMC servers in production had a .NET update before I could perform the upgrade. Could this be the problem?


Philip Goodridge | Senior Enterprise Monitoring Analyst

Enterprise Network Services
ICT Infrastructure Services | Information Technologies Branch
Department of Education

P: 07 3034 4484
Level 14 AM60 | 60 Albert Street | Brisbane QLD 4000
PO Box 15033 | City East QLD 4002

Inspiring minds. Creating opportunities. Shaping Queensland's future.
Please consider the environment before printing this email.



IMPORTANT: This email (including any attachments) may contain legally privileged, confidential or private information and may be protected by copyright. You may only use it if you are the person(s) to whom it was intended to be sent and if you use it in an authorised way. No one is allowed to use, review, alter, transmit, disclose, distribute, print or copy this email without appropriate authority.

If the email was not intended for you and was sent to you by mistake, please telephone or email me immediately, destroy any hard copies of this email, and delete it and any copies of it from your computer system. Any legal privilege and confidentiality attached to the email is not waived or destroyed by that mistake.

It is your responsibility to ensure that this email does not contain and is not affected by computer viruses, defects or interference by third parties or replication problems (including incompatibility with your computer system).

Occasional Advisor

Re: Password problem after migration IMC 7.3 E0506P07

Hi everyone, sorry for late reply. The issue was due to the new installation wasn't activated yet. When IMC is not activated, it's only allow the default admin to login. 

Hope it could help. The support was'nt able to inform about it.