IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

Patching confusion

 
Tony Barrett_2
Frequent Advisor

Patching confusion

I've got to say - patching iMC is confusing! I'm not sure which patches I should be using to bring our system up to date. I'm currently running iMC 7.3 E0506P09 on Windows and I can see E0605H05 and E0605P09 as the latest available (I'm assuming 'P' is patch, and 'H' is hotfix). Live Update says no patches available!

4 REPLIES 4
parnassus
Honored Contributor

Re: Patching confusion

Yes, it is. I agree with you 100%. Documentation is a little bit confusing (especially for Linux installs).

The first time I patched our first-time install of HPE IMC 7.3 E0605 to E0605P04 (done on the second half of July) I was full of doubts.

I was only sure about the fact I must use the (Patch) update package IMC 7.3 E0605P04 against only a deployment done with the GA release package IMC 7.3 E0605 (or eventually never released IMC 7.3 E0605H02 I hadn't).

The (Hotfix) update package IMC 7.3 E0605H5 follows the same restriction: it can be used (must be used) against an IMC 7.3 E0605P04 install.

Release Notes specify these restrictions very clearly.

Abour IMC LiveUpdate read this (It looks like E0605H05 solves the LiveUpdate issue experienced with previous IMC 7.3 versions).

With regards to the update process...I just let the update package to do it all by the installer and the I checked using the Intelligent Deployment Monitoring Agent (all deployed modules were updated, as necessary).

Tony Barrett_2
Frequent Advisor

Re: Patching confusion

Well, I'm glad I'm not the only one who thinks this is all a bit of a mess. I understand dependencies and all that, but HPE need to provide a clear upgrade/patching path, or at least make the live update process work as it should.

With that in mind then, can I go straight to E0605P04 from E0506P09, or are there any intermedie steps? I'm assuming then, once I'm at E0605P04, I can apply E0605H05..... I think.

parnassus
Honored Contributor

Re: Patching confusion


@Tony Barrett_2 wrote: Well, I'm glad I'm not the only one who thinks this is all a bit of a mess. I understand dependencies and all that, but HPE need to provide a clear upgrade/patching path, or at least make the live update process work as it should.

What I personally missed more (and I still miss) is the fact that IMC documentation related to Linux deployment is not updated/aligned (and it appears to have been written by someone or by a Team who never tried any IMC install really)...only recently one (yes, just one...this exact one) document popped up on HPE Support Portal about IMC+Linux+Oracle deployment (forgetting there are updates/corrections to documentation also related for IMC+Linux+MySQL deployment especially considering MySQL 5.7 [*] which was supported exactly since IMC 7.3 E0605 GA)...that is not sufficient IMHO, IMC deserves better docs even if - I learnt - using IMC on Linux means be part of a Special Users Club (the fight club!).

I fought few days before finding the right combination of IMC 7.3 E0605 on CentOS [**] 7.5 (1804) + MySQL (deployed via official RPM repositories, so using yum)...it was not an easy task even if I finally succeeded (and I have notes about what I did).

[*] MySQL 5.7 requires different parameters (some are supersedeed with respect to MySQL 5.6) so it was the most difficult part to have a proper environment ready for IMC 7.3 E0605 install (Also CentOS 7.5 is not like CentOS 6.x).

[**] CentOS 7.5 is not supported but binary compatible with TUV Red Hat Linux Server. I know.


@Tony Barrett_2 wrote: With that in mind then, can I go straight to E0605P04 from E0506P09, or are there any intermedie steps? I'm assuming then, once I'm at E0605P04, I can apply E0605H05..... I think.

No, from E0506P09 you can update to E0605 GA (May 2018) then, once in E0605, you can go to E0605P04 and finally, from E0605P04 to E0605H05 which is the very latest one.

Davide.

parnassus
Honored Contributor

Re: Patching confusion

Want to add that HPE IMC upgrade (macro) steps are detailed on each Release Notes (it's the roadmap).

Update of each deployed component happens automatically when you update the entire HPE IMC, see what happens (as example) here going from E0605P04 to E0605H05 on Linux executing the install.sh shell script found on the newer HPE IMC E0605H05 decompressed folder (the path is ../linux/install/components/common/deploy/):

HPE_IMC_7.3_update_from_HPE_IMC_7.3_E0605P04_to_HPE_IMC_7.3_E0605H05_06092018.png

and:  HPE_IMC_7.3_update_from_HPE_IMC_7.3_E0605P04_to_HPE_IMC_7.3_E0605H05_06092018_components_detail.png

Final result on deployed HPE IMC Modules (Components): HPE_IMC_7.3_update_from_HPE_IMC_7.3_E0605P04_to_HPE_IMC_7.3_E0605H05_06092018_components_detail_updated.png

 So the update process - once understood how to proceed - is pretty straightforward and, apparently, flawless.