IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem updating IMC (Linux Server) from E0605P06 to E0703

 
SOLVED
Go to solution
Lewis1
Occasional Advisor

Problem updating IMC (Linux Server) from E0605P06 to E0703

Hello,

I have a problem updating my IMC instance from the E0605P06 (end of 2018 version) to E0703 on my Linux Server. After the licence acceptation and before the installation I have a popup saying that "Common components are being upgraded" and then five seconds after the popup and the "installation" window vanish and nothing happens.

By looking at log files especially at this specific file /etc/iMC-Reserved/log/update_20190626xxxxxx.txt I found this error :

java.lang.UnsatisfiedLinkError: /opt/imc_install/iMC_PLAT_7.3_E0703_Enterprise_Linux/linux/install/common/jre_linux64/lib/libawt_xawt.so: libXrender.so.1: cannot open shared object file: No such file or directory

I solved it by installing the libXrender.x86_64 packet from yum but there is nothing more happening.

In my /etc/iMC-Reserved/log/install_20190626xxxxxx.txt file, I have nothing more than this message:

2019-06-26 18:31:14 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.install.wizard.InstallWizard$WizardData::needUpdateCommonComponents(257)] deploy.jar file not match(Mon Apr 01 15:19:44 CEST 2019 > Tue Sep 25 14:24:56 CEST 2018), update common components required.
2019-06-26 18:31:14 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.install.wizard.InstallWizard$WizardData::needUpdateCommonComponents(257)] deploy.jar file not match(Mon Apr 01 15:19:44 CEST 2019 > Tue Sep 25 14:24:56 CEST 2018), update common components required.
2019-06-26 18:31:16 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.CommonComponentUpdateLauncher::launchUpdater(502)] Launch common update program with: [/opt/imc_install/iMC_PLAT_7.3_E0703_Enterprise_Linux/linux/install/common/jre_linux64/bin/java, -Xmx256m, -Dinstaller.dir=/opt/imc_install/iMC_PLAT_7.3_E0703_Enterprise_Linux/linux/install, -cp, /opt/imc_install/iMC_PLAT_7.3_E0703_Enterprise_Linux/linux/install/components/common/deploy/deploy.jar, com.h3c.imc.deploy.CommonComponentUpdateLauncher, autoStart]

 

Did anyone else had this problem ?

Thank you.

 

 

4 REPLIES 4
jguse
HPE Pro

Re: Problem updating IMC (Linux Server) from E0605P06 to E0703

Hello,

Which Distribution + version are you running? What is the DB and version in use here, and is it local/remote?

If it fails right on the Common Components upgrade, this might indicate an OS/DB that isn't supported by the OpenJDK 11 that IMC E0703 is using, and a migration is needed. Not saying that will apply here, but it sounds similar to what happens on Windows in this situation.

Check your deploy\dmalog.txt for error as well, and see if you have messages related to windows\install\common\jre_windows\bin\java.exe

EDIT: The Linux equivalent of the above

Best regards,
Justin

Working @ HPE
Accept or Kudo
Lewis1
Occasional Advisor

Re: Problem updating IMC (Linux Server) from E0605P06 to E0703

Thank you for your response.

I'm using CentOS 7.3 and Mysql 5.6. There is only one IMC server and the database is located in the same server.

There is no message in the dmalog.txt file except this line when i stopped IMC:

2019-06-27 13:17:51 [INFO ] [AWT-EventQueue-0] [com.h3c.imc.deploy.dma.bG::actionPerformed(1075)] Do stop all process action

 

Highlighted
dasi66
Advisor
Solution

Re: Problem updating IMC (Linux Server) from E0605P06 to E0703

I remember a similar error. Did you unzip iMC_Plat.....zip on the server? If no do that and try again. Worked for me.

Lewis1
Occasional Advisor

Re: Problem updating IMC (Linux Server) from E0605P06 to E0703

That was exactly my case ! I removed the installation directory and unzipped again, and the installer is now working !!!

Thank you.