IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

Software Deployment "Transmission Protocol is not supported" (SCP)

Emerem96
Occasional Collector

Software Deployment "Transmission Protocol is not supported" (SCP)

I am very new to iMC and networking overall, I just started my vocational training 2-3 weeks ago. We had some problems with the SSH connection but everything seems to work fine now. Auto-Backups are running to. We use SCP as file transmission protocol. I am currently trying to update our switches (all HP 5500-HIs) to the latest software. I added the .zip in the Software Library and deployed it immediately, but it always fails during the process. The only information I get is that the transmission protocol is not supported and that I should configure a TP supported by the script.

 

Pic #1

Pic #2 (detail)

 

I also already tried it following this tutorial, but it did not work either.

 

I would be very thankful if you could help me with my problem.

3 REPLIES
VoIP-Buddy
Trusted Contributor

Re: Software Deployment "Transmission Protocol is not supported" (SCP)

Can you tell me what version of iMC you are running?  What operating system?  Windows or Linux?

 

Also, what software version is the 5500-HI running?  I just checked a 5500-HI in my lab and it does know about the SCP command.  I'm running Comware Software, Version 5.20.99, Release 5501P01on the 5500-HI.

 

Also, on the 5500-HI in addition to turning on the SSH service, did you also turn on the FTP and SFTP servers?  Does the login user have the rights to do sftp?

 

Comware does not come with services pre-enabled.  It is up to you to turn on the services that you need.  It's safer that way.

 

David

 

Emerem96
Occasional Collector

Re: Software Deployment "Transmission Protocol is not supported" (SCP)

I am running iMC 7.1 E0303 on a Windows Server. The switches are on A5500HI-CMW520-R5206. I don't have FTP / SFTP enabled. Could you specify what SCP command you mean? Thanks. 

C0LdWir3
Occasional Visitor

Re: Software Deployment "Transmission Protocol is not supported" (SCP)

Hi.

This is a rather old post.

I hope you got your problem solved.

Could you possibly supply the solution for others to find and use ?

Thank you :-)

And a note to other having similar issues is to go through this list from Lindsay Hill.
https://lkhill.com/hp-imc-troubleshooting-device-backup-problems/

Good luck