IMC
cancel
Showing results for 
Search instead for 
Did you mean: 

Update to PLAT 7.1 (E0303P16) issue

SOLVED
Go to solution
NeilR
Respected Contributor

Update to PLAT 7.1 (E0303P16) issue

I just updated the Std Platform from PLAT 7.1 (E0303P13) to PLAT 7.1 (E0303P16)  and had the following issue:

 

Main IMC web site would NOT respond to http://myhost:8080/imc or http://localhost:8080/imc when logged into the server.

 

However the self service site http://myhost:8080/selfservice/login.jsf was responding and I could log in as a user and check information, so the DB was up and stuff was running. 

 

The imc monitoring agent showed all processes started. I rebooted the server once to verify. Same result. Also https on 8443 gave same result.

 

NTA 7.1 (E0301P05) was upgraded to NTA 7.1 (E0301P08) at the same time.

 

I have rolled back to p13. Have not yet logged a ticket. Upgrade with caution at this point.

9 REPLIES
LindsayHill
Honored Contributor

Re: Update to PLAT 7.1 (E0303P16) issue

Yuck. Doesn't sound good.

 

My lab system upgraded cleanly, no issues noticed yet.

 

I'm not running any non-Standard modules though. Wonder if there's some connection there?

NeilR
Respected Contributor

Re: Update to PLAT 7.1 (E0303P16) issue

Yeah, well I've leraned to expect unusual results, as I've observed several anomolies that have not shown up on lab systems, so I always have a rollback plan.

 

Currently running 

iMC PLAT 7.1 (E0303P13) Max. License Quantity: 250 used 200

iMC NTA 7.1 (E0301P05) Max. NTA Devices: 5 used 4

iMC UAM 7.1 (E0302P16) Max. License Quantity:800 used 171 (this is low because the backup/failover systems has most of them until they all reauth)

iMC WSM 7.1 (E0303P08) Max. APs: 250 used 13 (uplift from PCM gave me all these and UAM)

 

Not such a custom or elaborate install I would think. All installed on one server so maybe something I did early on with UAM install/config has come back to bite due to a change they made.

 

The diversity of the potential conbinations makes it impossible to comreprehensively test, and as you have mentioned with your lab, the actual environment data and operations seems to produce differences. 

 

And not even consistently - i recently posted about a problem running cli - they were erroring can't telnet to device. Even though the telnet config tests good and backups are being made.  So I tested it again about a week ago, and success - ran fine. But today copying that same job - failure.

 

This sounds like data integrity/consistency issues to me.

 

Anyway I've got a snapshot of the upgraded config if I get time to visit with support.

rafter_1
Advisor

Re: Update to PLAT 7.1 (E0303P16) issue

Hi,

 

Yep, I also have upgraded (or attempted to!) and had the same issues, where the website wouldn't load.  I had to revert to snapshot as only had a short downtime window so no chance to investigate further.

 

Have you raised with HP?

 

I also updated NTA & WSM to the latest at the same time... Maybe that's the problem, but I usually do them all together - I think that was always recommended to have the latest addons anyway...

 

Glad I didn't forget my snapshot prior to upgrading!!

NeilR
Respected Contributor

Re: Update to PLAT 7.1 (E0303P16) issue

No not had a chance - as with many of these updates the "new" features aren't so critical, so finding the time to spend on the process is the issue.

 

It seems in the past that they have not responded to the on-line submit, so calling them is required. Maybe thats changed? let me know...

 

I also religously snapshot prior to every upgrade. As we use the 802 and mac authentication features can't tolerate any down time. 

 

I strongly recommend deploying the backup server feature if you haven't done that already - it synchs the user base and server certificate so authentication is seemless while the primary is down for updates and testing.

ICCNETMGR
Member

Re: Update to PLAT 7.1 (E0303P16) issue

I just wanted to confirm the same results with Std Platform from PLAT 7.1 (E0303P10) to PLAT 7.1 (E0303P16).

 

Installation is with the following modules: NTA, UAM and WSM.

Currently have a call into HP support and planning on taking it to level 2 support before rolling back our install.

 

HP support has recognized the problem is within the NTA module, iMC NTA 7.1 (E0301P08).

 


 

Solution(temporary workaround)

At this time, one can upgrade everything except the NTA, do not install past the iMC NTA 7.1 (E0301P05).

 

***If you have installed NTA P08, please call HP support as there is a specific set of tasks to go back, and therefore prefer not to be responsible for someone elses iMC environment.  I am rolling back to my previous snapshot.

Regards,
Dan Robinson
Lynn-Marie
Neighborhood Admin
Solution

Re: Update to PLAT 7.1 (E0303P16) issue

Hi Folks,

 

IMC tech support and R&D have been investigating.

 

There does NOT appear to be a problem with the PLAT v7.1 (E0303P16) patch.

There DOES seem to be a problem with the NTA v7.1 (E0301P08) patch.

 

About 3% of the time, after the NTA patch is applied and deployed, the login screen will not paint but appears as a blank web page. As a workaround, undeploying "Network Traffic Analyzer" and the "Network Traffic Analyzer Server“ recovers access to the platform and other (non-NTA) modules (allows the login screen to behave normally).

 

We are working hard to determine root cause and develop a fix, but we're not there yet. Stay tuned, and I'll post an update when there is news.

 

I hope this helps,

Lynn-Marie

NeilR
Respected Contributor

Re: Update to PLAT 7.1 (E0303P16) issue

thanks for the update! 

Lynn-Marie
Neighborhood Admin

Re: Update to PLAT 7.1 (E0303P16) issue

Clarification:

Dan recommended above that if you installed iMC NTA v7.1 (E0301P08) you should call HP support - BUT - if you updated to that patch successfully (as is the case 97% of the time) and were able to log into IMC afterwards, there is no problem.

 

If you have not yet updated, there is a small chance that you will run into this problem and you will either have to undeploy the affected components of NTA or roll back to the previous version to recover your access to the IMC GUI.

 

Thanks,

Lynn-Marie

rafter_1
Advisor

Re: Update to PLAT 7.1 (E0303P16) issue

Thanks all for the update, I'll steer clear of NTA update until a newer release!  Glad to see its been removed from the downloads site now!