IP Telephony - NBX
cancel
Showing results for 
Search instead for 
Did you mean: 

Dial Plan Problem

sarsippius
Occasional Contributor

Dial Plan Problem

I am not understanding a problem with my Dial Plan for my NBX 3000

 

Here is the deal, I have 9 NBX systems.  All have worked almost flawlessly.  My biggest problem that I can't figure out right now is why one Dial Plan keeps giving me the following error message:

 

Error at line 87: internal error TableEntry Create 1 53 16 4 4 WAN 0 26 syntax errors detected

 

This is what I have in my dial plan that I can't figure out:

 

Table Create 1 Internal 4 Digit Extenstions

/                                  ID  Entry   Digits  Min  Max   Class   Prio  Route

TableEntry Create    1   53       16        4      4        WAN     0       26

 

/                                               Route     Description

DestinationRoute Create    26           VTL Line to <location> 1600

 

/                                                        Route  Entry  DestinationExtension

DestinationRouteEntry Create     26        1        *0006

 

/                                                                   Route  Entry   OperId   Operation   Value

DestinationRouteOperation Create      26         1          1           prepend       xxx*xxx*xxx*xxx*

 

/                                                  PreTransId    Entry       Digits

PreTranslatorEntry Create      3                       6           xxx*xxx*xxx*xxx*

 

/                                                           PreTransId    Entry   OperId    Operation     Value

PreTranslatorOperation Create     2                      7           1             replace        <phone number>

 

 

 

This is the only thing that I can't get to work.  All my other routes are working fine, so I don't know what the problem is.  I have a least cost route that is 45 that works fine going through the NBX that I'm having problems with.

 

Any help would be greatly appreciated!!

3 REPLIES
bosoxfan
Trusted Contributor

Re: Dial Plan Problem

I have seen syntax errors when there has been an extra space at the end or something very strange like that.

export your dialplan, then retype delete that line  and retype it... make sure no spaces at the end.

 

I know it sounds weird, but I have seen things like that in the past

sarsippius
Occasional Contributor

Re: Dial Plan Problem

I have tried to retype the stuff, and tried to copy and paste from another dial plan that works.  Nothing is working for me that should be.  When I look at the dial plan under modify, I don't see my TableEntry Create 53 in the dial plan.  I guess if the syntax is not correct, it just ignores that line?

 

Would it cause any problems to edit it right there on the system?

 

Thanks for any help!!

sarsippius
Occasional Contributor

Re: Dial Plan Problem

Changed the route number and it worked!