IP Telephony - NBX
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade fail from 6055 to 6063 v3001bri

maknbx_1
Frequent Advisor

Upgrade fail from 6055 to 6063 v3001bri

Hi all,



I have a strange problem with a new NBX V3001BRI with a release software R6_0_55.



This NBX is new from mi distributor, now i must upgrade the release to R6_0_63.



I try to upgrade much time but the error is the same : when the file is in state unpack (from serial - CLI) after show me error: -5 software upgarade canceled.



The strange is the file i use is the same that i put in another v3001bri before and is not corrupt and the upgrade done.



the lan cable is the same that previous upgrade in another nbx, i try to download again but nothing, try to change the lan port on the nbx but nothing, i try to upgrade to R6_0_59 but the error is the same.



Also i try to purge database cdr and voicemail, also if the nbx is new, but the error is the same.



 



Anyone help me?



 



Thanks

7 REPLIES
merlin_1
Super Advisor

Re: Upgrade fail from 6055 to 6063 v3001bri

That is interestng . I would suggest to check the code on our partner site first . I am not exactly sure . You state a hyperterm message that looks like the software is incompatable . Do you get any errors on netset ?



maknbx_1
Frequent Advisor

Re: Upgrade fail from 6055 to 6063 v3001bri

Yes is strange, if possible for strange case the software in v3001R is another software, i suppose and i try the machin is function.......



 



I try with three different browser and the error is the same...



When with hypeterminal show me the error : -5 on browser appear the little window describe to software upgrade fail unable to unpack the software..



 



In last two try the browser block on oage where i put the file and clik upgrade and on hyperterminal stay for more one hour to : file upload beginning...........after more hours for me only "brutal shudown" press the button to shutdown and then i push again to restart the nbx.



 



Is it possibile to clear someone via CLI or another way?



About my ten and much more years with NBX this is the first time that the nbx failed to upgrade, like when the file of software i get into nbx is corrupt or for a differen model of nbx.....



THANKS

bosoxfan_1
Super Advisor

Re: Upgrade fail from 6055 to 6063 v3001bri

I have seen this failure sometimes when trying to upgrade over a slower WAN link..



Here is what I suggest:



1. ftp into the box and look for any folder /htfs0/R6_0_63



2. If there is a folder labeled /htfs0/ R6_0_63, delete it and everything in it.



3. look and see if there is an R6_0_63_v3001AnalogBri.taz file or R6_0_63_v3001analogBri..tar file and delete that. This would be in /htfs0 folder



4. now go to /htfs0/tmp.. see if there is a folder labeled R6_0_63.. if so, delete that and everything in it



5. reboot the NBX



4. Place the PC that has the 6.0.63 image on the same subnet as the NBX and try it again !



maknbx_1
Frequent Advisor

Re: Upgrade fail from 6055 to 6063 v3001bri

THNAKS,



 



i follow your word one by one and i try the file you say and after i deleted it.



After i reboot the NBX.



 



After i try to upgrade again but unfortunately the same error show me, on browser :



Software Upgrade fail.



Failed to uncompress tar file



On hyper term show, after raw software upgrade (file unpack)  beginning...



ERROR: -5



s



0xecf4c74 (tEmWeb) : Software upgrade cabceled.



And after show VxWorks Login tree time......



On a log file doesn't show anything, i upgrade the NBX with notebook (and another one) with same subnet of lan and with direct connection with lan cable..



Now i find another way with ftp on nbx the file i try to put on the nbx in directory htfs0, but like after, not find on directory tmp.



I don't know.....





bosoxfan_1
Super Advisor

Re: Upgrade fail from 6055 to 6063 v3001bri

wow. something really strange going on.



one other thing to try is to force the unit to run fsck.. maybe a bad block on the disk and the upgrade is writing to it.



shut down the web and unplug the unit and then plug it back in. . this should force fsck to run and



check the console to see if any bad blocks.



 



If that does not do it, I would RMA the unit.



jprichard
Advisor

Re: Upgrade fail from 6055 to 6063 v3001bri

I had something similar happen with a V3001 that was running R6.0.55, and trying to upgrade it to R6.5.20



It never unpacked the tar file.



Tried R6.5.22, same thing-- failed to unpack the tar file.



Even got to the point that the CLI stopped responding as well, and took a hard boot to get it working again.



Also would not let me do a backup.....so couldn't go forward, couldn't go backward.



Ended up RMA'ing the V3001, and then only stayed at R6.0.63...not willing to try R6.5.x at all-- too many bad experiences



 



merlin_1
Super Advisor

Re: Upgrade fail from 6055 to 6063 v3001bri

One thing I have been watching



 



Have you tried back revving or using any different codes besides 6.5 code ?